Display the default CC list when listing all components of a product in editcomponents.cgi

RESOLVED FIXED in Bugzilla 4.4

Status

()

Bugzilla
Administration
--
enhancement
RESOLVED FIXED
11 years ago
5 years ago

People

(Reporter: Albert Ting, Assigned: selsky)

Tracking

2.23.3
Bugzilla 4.4
Bug Flags:
approval +

Details

Attachments

(1 attachment, 1 obsolete attachment)

1.29 KB, patch
Frédéric Buclin
: review+
Details | Diff | Splinter Review
(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: 

First off, thanks Max for completing the default-cc (bug 38922).  Glad to see it's finally part of the source code.

But I'd like to have edit component list page also show the default cc's.  Makes it easier to review them, rather than clicking each component one at a time. 

Reproducible: Always
(Reporter)

Comment 1

11 years ago
Created attachment 250212 [details] [diff] [review]
suggested patch, v1

suggested patch
Attachment #250212 - Flags: review?(LpSolit)

Updated

11 years ago
Assignee: administration → altlst
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Bugzilla 3.2
Version: unspecified → 2.23.3

Comment 2

11 years ago
Comment on attachment 250212 [details] [diff] [review]
suggested patch, v1

>--- Bugzilla/Component.pm	2006-12-22 10:10:21.000000000 -0800

>+sub initial_cc_names {
>+    my $self = shift;
>+    return join(', ', map($_->login, @{$self->initial_cc}));
>+}

I don't want to see such methods. We already have initial_cc(). Let editcomponents.cgi extract login names and pass it to the template where the override trick is already in use.
Attachment #250212 - Flags: review?(LpSolit) → review-

Updated

11 years ago
Duplicate of this bug: 383998

Comment 4

10 years ago
Bugzilla 3.2 is now frozen. Only enhancements blocking 3.2 or specifically approved for 3.2 may be checked in to the 3.2 branch. If you would like to nominate your enhancement for Bugzilla 3.2, set the "blocking3.2" flag to "?", and either the target milestone will be changed back, or the blocking3.2 flag will be granted, if we will accept this enhancement for Bugzilla 3.2.
Target Milestone: Bugzilla 3.2 → Bugzilla 4.0

Comment 5

10 years ago
Albert, any progress?
(Reporter)

Comment 6

9 years ago
Frederic,

  I am unclear regarding your suggestion in comment #2.  components/list.html.tmpl is referenced several times in editcomponents.cgi, meaning I'd have to build initial_cc_names each time list.html.tmpl process (or define it once near the top). Plus the current list.html.tmpl column setting is already referencing Component.pm names, so am merely extending it.
(Assignee)

Comment 7

6 years ago
Created attachment 619553 [details] [diff] [review]
patch, v2

I looped through the logins in initial_cc using bug/create/create.html.tmpl as an example.
Assignee: altlist → selsky
Attachment #250212 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #619553 - Flags: review?(LpSolit)

Comment 8

6 years ago
Comment on attachment 619553 [details] [diff] [review]
patch, v2

>+       heading => "Initial CC"

"Initial CC list" would be clearer, IMO.


>+  [%   initial_cc_list.push(cc_user.login) %]

Nit: the indentation is incorrect.


The order of the columns is now pretty weird:

  Default Assignee 	Active	 	Initial CC 	QA Contact


It should rather be:

  Default Assignee 	QA Contact 	Initial CC 	Active


This can be fixed on checkin. r=LpSolit
Attachment #619553 - Flags: review?(LpSolit) → review+

Updated

6 years ago
Flags: approval+
Keywords: relnote

Comment 9

6 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified template/en/default/admin/components/list.html.tmpl
Committed revision 8228.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Summary: display default-cc list on the edit component page → Display the default CC list when listing all components of a product in editcomponents.cgi

Comment 10

5 years ago
Added to relnotes for 4.4.
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.