Add link to comment in bugmail notification

RESOLVED FIXED in Bugzilla 4.4

Status

()

Bugzilla
Email Notifications
P2
enhancement
RESOLVED FIXED
12 years ago
7 years ago

People

(Reporter: whimboo, Assigned: dkl)

Tracking

({polish})

unspecified
Bugzilla 4.4
polish
Bug Flags:
approval +

Details

(Whiteboard: [wanted-bmo])

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Receiving bugmail with a new comment makes it hard to find the entry for long bug conversations.

We should have a link to the comment in the bugmail so you can directly jump to the entry e.g. https://bugzilla.mozilla.org/show_bug.cgi?id=363831#c35

Comment 1

11 years ago
Yeah, that's a pretty good idea. :-)
Keywords: polish
Priority: -- → P2
This would be really useful every day for everyone reading bugmail.
Max, is it hard to implement? Say more than 5 lines?
Which file do we need to patch?

Updated

7 years ago
Duplicate of this bug: 645165
(Assignee)

Updated

7 years ago
Whiteboard: [wanted-bmo]
(Assignee)

Comment 4

7 years ago
Created attachment 523095 [details] [diff] [review]
Patch to add comment link near comment in email notification (v1)

Adds comment link to text version of email notification. HTML version already has this.

Dave
Assignee: email-notifications → dkl
Status: NEW → ASSIGNED
Attachment #523095 - Flags: review?(mkanat)

Comment 5

7 years ago
Comment on attachment 523095 [details] [diff] [review]
Patch to add comment link near comment in email notification (v1)

Seems reasonable.
Attachment #523095 - Flags: review?(mkanat) → review+

Updated

7 years ago
Flags: approval+
Target Milestone: --- → Bugzilla 5.0
(Assignee)

Comment 6

7 years ago
Thanks.

trunk:
Committing to: bzr+ssh://dlawrence%40mozilla.com@bzr.mozilla.org/bugzilla/trunk
modified template/en/default/email/bugmail.txt.tmpl
Committed revision 7996
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Blocks: 697371
(Reporter)

Comment 7

7 years ago
Has this been disabled again? Since a couple of days I don't see such a link anymore in the bug mail from bmo.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Henrik Skupin (:whimboo) from comment #7)
> Has this been disabled again? Since a couple of days I don't see such a link
> anymore in the bug mail from bmo.

yes, see bug 703501
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Resolution: FIXED → WONTFIX

Comment 9

7 years ago
No reason to mark *this* bug as WONTFIX. The patch has been committed, even if it has been backed out in another bug.
Resolution: WONTFIX → FIXED
You need to log in before you can comment on or make changes to this bug.