Last Comment Bug 365764 - I would like to set spellchecking language per recipients
: I would like to set spellchecking language per recipients
Status: RESOLVED DUPLICATE of bug 69687
:
Product: Thunderbird
Classification: Client Software
Component: Message Compose Window (show other bugs)
: unspecified
: All All
: -- enhancement (vote)
: ---
Assigned To: Scott MacGregor
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-03 00:28 PST by Mattias Tollet
Modified: 2007-01-10 18:27 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Mattias Tollet 2007-01-03 00:28:25 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: version 1.5.0.9 (20061207)

I use spellchecking when writing mails. As I often switch between Swedish and English when writing mails, depending on who I write to, I need to switch language quite often. It would be nice if the email composer could chooose spellchecking language depending on who I write to rather than what language I used in my last email.

Reproducible: Always

Steps to Reproduce:
1. Select language A when writing email to recipient X
2. Write another email to recipient Y that I know prefers language B
3.
Actual Results:  
I need to select language B manually for recipient Y.

Expected Results:  
The email composer recognises that recipient Y prefers language B and sets the spellchecking accordingly.

I can think of two ways how this would be implemented:
1) Add the possibility to associate a language with address-book entries
2) Remember what spellcheck language was last used on a per To-field basis
Comment 1 Jo Hermans 2007-01-03 03:04:11 PST
Duplicate of Core bug 69687? See also Suite bug 260533.
Comment 2 Wayne Mery (:wsmwk, NI for questions) 2007-01-10 18:27:12 PST
#1 per address (book entry) is bug 202207
#2 is sort of bug 69687

*** This bug has been marked as a duplicate of bug 69687 ***

Note You need to log in before you can comment on or make changes to this bug.