Acid2 occasionally breaks (with an extension that pokes document.documentElement during address bar's ValueChange event)

RESOLVED DUPLICATE of bug 436717

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 436717
11 years ago
9 years ago

People

(Reporter: dao, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

1.02 KB, application/x-xpinstall
Details
(Reporter)

Description

11 years ago
I can see a red box below the face for several weeks now: attachment 249817 [details]
The test passes when loaded in a background tab.

There is a similar looking issue with GTK (bug 365680), but apparently the cause is different (bug 365680 testcases work).

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070103 Minefield/3.0a2pre ID:2007010304 [cairo]
(Reporter)

Comment 1

11 years ago
Created attachment 250357 [details]
problematic extension source

Only happens with this extension installed (and "Auto-detect locales" enabled): https://addons.mozilla.org/firefox/3414/

I'm attaching the source, because to me it looks like it doesn't modify the content. So I still think this is a Mozilla bug. Since Acid2 breaks after the DOMContentLoaded event, I think the first point to take a look at is the pageLoad() method.
(Reporter)

Comment 2

11 years ago
Created attachment 250393 [details]
test extension

I have no idea what's happening here. I narrowed it down to this:

> window.addEventListener("load", function() {
>   gURLBar.addEventListener("ValueChange", function() {
>     if (gBrowser.selectedBrowser.docShell.QueryInterface(Components.interfaces.nsIWebNavigation).document.documentElement)
>       document.documentElement.getAttribute("lang");
>   }, true);
> }, false);
Attachment #250357 - Attachment is obsolete: true

Updated

11 years ago
Summary: Acid2 occasionally breaks → Acid2 occasionally breaks (with an extension that pokes document.documentElement during address bar's ValueChange event)
(Reporter)

Comment 3

11 years ago
Here's a new way to reproduce:

1. start Firefox with a new profile
2. open http://www.webstandards.org/files/acid2/test.html#top
3. open the DOM Inspector
4. expand the node tree until you're at the very last element (IMG)
5. select IMG

The image blinks and the red box appears.
This isn't necessarily a bug, because DOM Inspector actively changes the content by using scrollIntoView() or so.
(Reporter)

Comment 4

11 years ago
Now back to comment 2. I disabled the blinking feature of DOMi so that it doesn't break things. Then I compared all the properties of that image (mentioned in comment 3):

                          | PASS   | FAIL
--------------------------|--------|-------
 Box Model/Position/y     |        |
--------------------------|        |
 JS/y                     | 156    | 0
--------------------------|        |
 JS/offsetTop             |        |
--------------------------|--------|-------
 Computed Style/font-size | 240px  | 16px

The latter looks a bit like bug 365680.
(Reporter)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 436717
You need to log in before you can comment on or make changes to this bug.