Title bar displays email address rather than Account name

RESOLVED FIXED in Thunderbird 3

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: Scott, Assigned: Žiga Sancin)

Tracking

Trunk
Thunderbird 3

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20060601 Firefox/2.0.0.1 (Ubuntu-edgy)
Build Identifier: 

This may sound trivial, but I just don't like my email address displayed so prominently across the titlebar.

Not everyone has full privacy at their computers and therefore may not wish to share a particular email address with everyone in the vacinity.

I've alwyas found it odd that the mailbox name wasn't displayed anyway.

For example a user has an email address of "xxxx@yyy.org" but names the corrospoinding mailbox "Business".  Instead of "Business" in the titlebar xxxx@yyy.org" is displayed instead.

Not good...

Reproducible: Always

Steps to Reproduce:
1. Open Thunderbird
2. Select a Mailbox

Actual Results:  
Mailbox's email address displays in title bar rather than mailbox name.

Expected Results:  
Display Mailbox name in title bar instead.

This may sound trivial, but I just don't like my email address displayed so prominently across the titlebar.

Not everyone has full privacy at their computers and therefore may not wish to share a particular email address with everyone in the vacinity.

I've alwyas found it odd that the mailbox name wasn't displayed anyway.

For example a user has an email address of "xxxx@yyy.org" but names the corrospoinding mailbox "Business".  Instead of "Business" in the titlebar xxxx@yyy.org" is displayed instead.

Not good...
(Reporter)

Comment 1

11 years ago
This also applies to the Windows version as well.

Comment 2

11 years ago
Note that if a folder in Local Folders or a RSS account is selected, there is no "for..." appended to the folder name in the window title.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Summary: Title bar displays email address rather than Mailbox name → Title bar displays email address rather than Account name
Version: unspecified → Trunk
(Assignee)

Updated

10 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

10 years ago
Assignee: mscott → bisi
Status: ASSIGNED → NEW
(Assignee)

Comment 3

10 years ago
Created attachment 313358 [details] [diff] [review]
seven nation army

What do you think Magnus? Do you have a better suggestion about the name of the pref?
Attachment #313358 - Flags: review?(mkmelin+mozilla)
(In reply to comment #3)
> What do you think Magnus? Do you have a better suggestion about the name of the
> pref?
> 
Do we actually need a pref for it?
(Assignee)

Comment 5

10 years ago
Well, some users may prefer to see the email address and some may prefer to see the account name. But you're right, it could be done without a pref. If somebody wants the email address displayed in the title bar, then she/he can still set her/his email as the account name. Thunderbird should enforce full privacy, so we better do it without a pref.

Hum, is Bryan the final UI decision maker? Can I proceed, Bryan? :)
I'm inclined to just move towards changing the default and not having a pref for this.  There's an awkward inconsistency happening and I'm not sure I understand why.  

When you're looking at the top level of your account it's called $ACCOUNT_NAME and then when you choose the Inbox or other folder it's called Inbox for $EMAIL instead of Inbox for $ACCOUNT_NAME.

By default your email address is used to name the account, so people who didn't name their account something other than the default would continue to see the same behavior.

I would go for the change, minus the pref.
(Assignee)

Comment 7

10 years ago
Created attachment 313669 [details] [diff] [review]
change without a pref
Attachment #313358 - Attachment is obsolete: true
Attachment #313358 - Flags: review?(mkmelin+mozilla)
Attachment #313669 - Flags: review?(mkmelin+mozilla)

Comment 8

10 years ago
Agree, we don't need a pref for this, the new default is much better! The current one is bad especially with multiple identities.

Though now the "for" is a bit odd. "Inbox for Work mail" e.g.. We should change that too, either "-" or "|" would be nice I think.  Either would be nice imo, we use - in the Recent menus already, so perhaps that's best. 

Comment 9

10 years ago
Created attachment 313692 [details]
little illustrating screenshot with - and |
Nice catch!  I think the dash looks fine.
(Assignee)

Comment 11

10 years ago
While I'm at it... Should I also change brandShortName to brandFullName in the title bar (title - Mozilla Thunderbird instead of title - Thunderbird)?
Status: NEW → ASSIGNED
(Assignee)

Updated

10 years ago
Attachment #313669 - Attachment is obsolete: true
Attachment #313669 - Flags: review?(mkmelin+mozilla)

Comment 12

10 years ago
Firefox uses the full brand name so yes, I think it's a good idea for us to do it too!
(Assignee)

Comment 13

10 years ago
Created attachment 313924 [details] [diff] [review]
change without a pref v2
Attachment #313924 - Flags: review?(mkmelin+mozilla)

Comment 14

10 years ago
Comment on attachment 313924 [details] [diff] [review]
change without a pref v2

That should only be "-" since the we will add surrounding spaces a few rows down.

I've adjusted that, will check this in shortly. Thanx for the patch! A quite nice little improvement.
Attachment #313924 - Flags: review?(mkmelin+mozilla) → review+

Comment 15

10 years ago
Checking in mail/base/content/commandglue.js;
/cvsroot/mozilla/mail/base/content/commandglue.js,v  <--  commandglue.js
new revision: 1.91; previous revision: 1.90
done
Checking in mail/locales/en-US/chrome/messenger/messenger.properties;
/cvsroot/mozilla/mail/locales/en-US/chrome/messenger/messenger.properties,v  <--  messenger.properties
new revision: 1.54; previous revision: 1.53
done

->FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3
(Assignee)

Comment 16

10 years ago
Thanks Magnus! :)

Comment 17

10 years ago
hmm... was there any reason to substitute titleMailPreHost with a hardcoded string?..

Comment 18

10 years ago
Yes, it should be - for all localizations. We don't localize the one before the brand name either.
You need to log in before you can comment on or make changes to this bug.