HTML Comment tag with dash characters, <!-- my comment ------ -->

RESOLVED DUPLICATE of bug 214476

Status

()

Toolkit
View Source
RESOLVED DUPLICATE of bug 214476
11 years ago
10 years ago

People

(Reporter: joo, Unassigned)

Tracking

({xhtml})

1.8 Branch
x86
Windows XP
xhtml
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

Yeah, it's simple
If I use comment tag with lots dash characters like 

<!-- some comments ------------------- --> or
<!-- some comments --------------------->

Firefox initilize all text as a comment after comment tag.
so table layout is broken.

when I make a code snippets like

<!-- comment -------------->
<div>my name</div>
<div>my age</div>
<!-- comment -------------->

my name and my age are goin to be comment with Firefox.
IE doesn't happen

so I had to change my html source code
before : <!-- my comment --------------> 
after : <!-- my comment ++++++++++++ --> 

I should change dash character to the other one.

Check this out...

Reproducible: Always

Steps to Reproduce:
1. make a html file on your computer
2. make a code like whole html document
3. use a comment tag having dash character inside
Actual Results:  
no special setup
(Reporter)

Comment 1

11 years ago
GO! Firefox! I love it!
Keywords: xhtml
Version: unspecified → 2.0 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Summary: Crash if I use a HTML Comment tag with dash characters, <!-- my comment ------ --> → HTML Comment tag with dash characters, <!-- my comment ------ -->
Duplicate of bug: 214476
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.