bidi mirroring broken for quotes (at least with hebrew)

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: Danny Sadinoff, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

parens and brackets are properly mirrored, but double and single curly quotes are not.

Reproducible: Always

Steps to Reproduce:
1. write web page with hebrew in dir=rtl
2. surround text with curly quotes
3. observe how they're not mirrored per http://unicode.org/reports/tr9/#Mirroring
Actual Results:  
quotation marks not mirrored

Expected Results:  
quotation marks mirrored

this fails on the PC and succeeds on OSX.
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0 Branch
(Reporter)

Comment 1

11 years ago
Created attachment 250434 [details]
test case showing parens mirroring but quotes not.
(Reporter)

Comment 2

11 years ago
weird.  "view source" does the right thing.  maybe this is another font issue?
(Reporter)

Comment 3

11 years ago
Whoops. just realized that I was reading the unicode 5 tables, not the v4 specs, and it seems that the problem is actually in OSX, which has the unicode-5 semantics too early. 

Double-quotes have the mirrored property only in unicode 5.
I'll cancel this bug and resubmit as an OSX bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.