Closed Bug 365914 Opened 14 years ago Closed 14 years ago

Inproper parsing of email address in messages produced by MS Exchange

Categories

(Thunderbird :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 254519

People

(Reporter: carlos-spam, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20060601 Firefox/2.0.0.1 (Ubuntu-edgy)
Build Identifier: 1.5.0.9 (20061206)

Today I received an email which made thunderbird a bit dizzy. The From: field from this message was:

From: =?iso-8859-2?Q?Brzezi=F1ski=2C_Maciej?= <yyyy@xxxx.xx>

(email address was modified to not feed spiders, but it does not matter to this bug report). The problem however is that on the list of messages (Inbox), the sender was show just "Brzesinski" while it shall be "Brzezinski Maciej". Next, hitting reply opened composition from with two recipients. One is "Brzezinski" and second is "Maciej <yyyy@xxxx.xx>". 

The bug seem to lurk in email parsing code as it does not matter it is From: or CC:. If this is formatted the same way, the same oddities occur.

Other message headers that may help are:

X-MimeOLE: Produced By Microsoft Exchange V6.5
Content-class: urn:content-classes:message

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
This is a parsing bug, but it's not related to Exchange.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 254519
You need to log in before you can comment on or make changes to this bug.