If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

spelling checker flags "Thunderbird" as a misspelled word

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
--
minor
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: myk, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
The spelling checker flags the proper noun "Thunderbird" as a misspelled word.  Presumably we don't want to add every proper noun into the dictionary, but the name of the product seems like one it would be useful to add.

I should note that over 31 million web pages contain the word "thunderbird" according to Google, and the first 100 results reference schools, an automobile model, a real estate agency, lodging of various kinds, a card game, a furniture manufacturer, and various other entities with the name in addition to the software, so it's certainly not uncommon.
(Assignee)

Comment 1

11 years ago
That's odd, we added Thunderbird to the default en-US dictionary on the 1.8 branch for Thunderbird 2 along with Firefox, Mozilla, Google, eBay, SUSE, etc. Do those other words fail for you too Myk? 

Here's the full  list of words we added to the dictionary:

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=en-US.dic&branch=&root=/cvsroot&subdir=mozilla/extensions/spellcheck/locales/en-US/myspell&command=DIFF_FRAMESET&rev1=1.1&rev2=1.2

Can you double check that you are using the en-US dictionary as well?


(Reporter)

Comment 2

11 years ago
Hmm, how bizarre.  Now I can't reproduce the problem either, although I tested with both 1.5 and with the latest 2 nightly before filing the bug.  But perhaps when I thought I was testing with 2 I was actually testing with 1.5 again.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Assignee)

Comment 3

11 years ago
ah that could be it. 1.5 would have flagged Thunderbird as being mispelled.
You need to log in before you can comment on or make changes to this bug.