Install of 2.0.0.1 won't proceed even after closing all applications and restarting Firefox

RESOLVED INCOMPLETE

Status

()

Toolkit
Application Update
RESOLVED INCOMPLETE
12 years ago
10 years ago

People

(Reporter: Robert Abrams, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

When I open Firefox, it says 2.0.0.1 will be installed, the screen indicates files are being copied or unpacked.  Then after a two or three second pause, I get the message to close applications because some of the files could not be changed.  I have administrator privileges on the machine and close all open applications, but the install still fails.  The old version then appears and works just fine.
I have tried with Spybot uninstalled, but have not tried to disable my McAfee which has not affected other installs.  Thanks in advance for your help.

Reproducible: Always

Steps to Reproduce:
1.Start Firefox (even with all other applications closed and with administrator privileges)
2.
3.
Actual Results:  
Am told the update is underway, then a slight pause, and message that some of the files could not be changed, then the old version comes up and works fine.

Expected Results:  
After closing applications I expected the install of 2.0.0.1 to be completed
You should try the following:

1, Close Firefox with File > Exit
2, Open the Windows Task Manager and select the Processes tab
3, Look for firefox.exe entries

There should be none, but some trojans & malware keep firefox open. If firefox.exe is still there see http://kb.mozillazine.org/Firefox.exe_always_open for more info on that.

If there are no firefox.exe present, then please check the file <firefox dir>\updates\last-update.log (eg C:\Program Files\Mozilla Firefox\updates\last-update.log). If the file was modified at the last update attempt, then please attach the file to this bug.
Version: unspecified → 2.0 Branch
-> incomplete, waiting for Feedback.

Robert, if you still see the reported bug with a recent release like Firefox 2.0.0.4, feel free to reopen this bug. It would be great then, if you could answer the questions / attach the log.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INCOMPLETE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.