Crash trying to save image file to hard disk

VERIFIED DUPLICATE of bug 34050

Status

SeaMonkey
UI Design
P3
critical
VERIFIED DUPLICATE of bug 34050
18 years ago
13 years ago

People

(Reporter: shrirang khanzode, Assigned: Bill Law)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Pls reassign if component is incorrect.
I crash trying to save any image file. Go to the url mentioned and right click 
on the banner image on top. 
Select "Save Image As".
Selece a location and press OK
Observe that image gets saved but the browser crashes.

Stack trace:

Trigger Type:  Program Crash 

 Trigger Reason:  Access violation 

 Thread ID:   

 Call Stack:    (Signature = nsBufferedOutputStream::Flush c7483f35) 
     
   nsBufferedOutputStream::Flush 
                                       
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsBufferedStreams.cpp, line 302]
     
   nsBufferedOutputStream::Close 
                                       
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsBufferedStreams.cpp, line 269]
     
   nsStreamXferOp::OnStopRequest 
                                       
[d:\builds\seamonkey\mozilla\xpfe\components\xfer\src\nsStreamXferOp.cpp, line 
434]
     
   nsHTTPChannel::ResponseCompleted 
                                       
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPChannel.cpp, line 
1554]
     
   nsHTTPServerListener::OnStopRequest 
                                       
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cp
p, line 631]
     
   nsOnStopRequestEvent::HandleEvent 
                                       
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 
307]
     
   nsStreamListenerEvent::HandlePLEvent
                                       
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 
106]
     
   PL_HandleEvent 
                                       
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 576]
     
   _md_EventReceiverProc 
                                       
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 1032]
     
   USER32.dll + 0x1820 (0x77e71820)
(Reporter)

Comment 1

18 years ago
reassigning
Assignee: don → law
dup.

*** This bug has been marked as a duplicate of 34050 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

18 years ago
verif
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.