Last Comment Bug 365966 - infinite recursive call in VFY_VerifyDigestDirect
: infinite recursive call in VFY_VerifyDigestDirect
Status: RESOLVED FIXED
:
Product: NSS
Classification: Components
Component: Libraries (show other bugs)
: trunk
: All All
: P1 normal (vote)
: 3.12
Assigned To: Alexei Volkov
:
Mentors:
: 339878 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-04 14:31 PST by Alexei Volkov
Modified: 2007-01-24 11:56 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
changing calling function name (1020 bytes, patch)
2007-01-08 15:26 PST, Alexei Volkov
nelson: review+
Details | Diff | Splinter Review

Description Alexei Volkov 2007-01-04 14:31:04 PST
Integrated as a part of patch for bug 320583.

SECStatus
VFY_VerifyDigestDirect(const SECItem *digest, const SECKEYPublicKey *key, 
		       const SECItem *sig, SECOidTag encAlg, 
		       SECOidTag hashAlg, void *wincx)
{
     return VFY_VerifyDigestDirect(digest, key, sig, encAlg, hashAlg, wincx);       
}
Comment 1 Robert Relyea 2007-01-05 14:37:29 PST
The inner call should be vfy_VerifyDigest.

bob
Comment 2 Nelson Bolyard (seldom reads bugmail) 2007-01-05 17:31:33 PST
Alexei, Thank you for testing this new code in NSS 3.12.  
It clearly hasn't previously been tested.
Please code a patch per bob's comment 1, and test that to see if it works.  
Also, please add a comment to this bug explaining what command (test program)
found this bug, and plan to add that to the appropriate NSS test script.
Comment 3 Alexei Volkov 2007-01-08 15:26:20 PST
Created attachment 250902 [details] [diff] [review]
changing calling function name

Tests will be integrated as a part of a fix for bug 301496.
Comment 4 Nelson Bolyard (seldom reads bugmail) 2007-01-08 15:52:43 PST
Comment on attachment 250902 [details] [diff] [review]
changing calling function name

r=nelson
Comment 5 Alexei Volkov 2007-01-08 16:37:52 PST
/cvsroot/mozilla/security/nss/lib/cryptohi/secvfy.c,v  <--  secvfy.c
new revision: 1.21; previous revision: 1.20
Comment 6 Alexei Volkov 2007-01-24 11:56:57 PST
*** Bug 339878 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.