After clicking on a form control (radio button, pop-up menu, etc), it is selected.

VERIFIED DUPLICATE of bug 129840

Status

Camino Graveyard
HTML Form Controls
VERIFIED DUPLICATE of bug 129840
11 years ago
11 years ago

People

(Reporter: Jolin Warren, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.2pre) Gecko/20070104 Camino/1.1a1+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.2pre) Gecko/20070104 Camino/1.1a1+

In the Camino preferences, I have DEselected the option "Tab selects text fields and Form buttons, pop-up menus and lists" (in the Web Features category). However, if I click on a pop-up menu, radio button, tick box, etc., the widget is then selected. So pressing space or the down arrow actually changes the status of the widget instead of scrolling the page.

If the 'tab selects form buttons, pop-up menus and lists' option is deselected in the prefs, then Camino should never select these elements, even if the mouse is used to change them. To me, this option states that the user doesn't want the keyboard to ever focus on these elements. Otherwise the option is of limited use. With the option deselected, the only way to change the status of these widgets is with the mouse. If using the mouse then selects the widgets, I may as well have tabbed to them.

Reproducible: Always

Steps to Reproduce:
1. In 'Preferences', 'Web Features', un-tick the box "Form buttons, pop-up menus and lists"

2. Go to a page with a form (such as this Bugzilla bug 'enter bug' page).

3. Click on a pop-up menu and change the item selected by the menu; release the mouse.
Actual Results:  
The menu widget itself is now selected. Pressing the down arrow will change the menu selection.

Expected Results:  
The menu widget should not be selected. Pressing the down arrow should scroll the page.

Comment 1

11 years ago
I don't understand why select-on-click is a such a big problem, and this is almost certainly something that would be a Core bug, rather than a Camino bug.

I'll bet a hundred bucks Core WONTFIXes it, though.

cl

Comment 2

11 years ago
I want to say I saw a core bug about this sometime semi-recently, so I wouldn't make that bet too quickly. Could someone check core for this?

Comment 3

11 years ago
Maybe bug 129840, which this sounds like a dupe of anyway?

cl
The issue with pop-up selects is at least partially a Camino bug (bug 154226 / bug  294882).

Comment 5

11 years ago
Well, bug 154226 is sort of the opposite of this bug, and bug 294882 is about us focusing it late, screwing up JS actions, not about focusing it at all.  I was probably thinking of bug 129840, which definitely sounds like a dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 129840

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.