Can't copy address contacts if they don't have email address!!

RESOLVED DUPLICATE of bug 248786

Status

Thunderbird
Address Book
--
minor
RESOLVED DUPLICATE of bug 248786
11 years ago
10 years ago

People

(Reporter: Jon Jenkins, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: version 1.5.0.9 (20061207)

I have imported my address book from Outlook but because TB does not support hierarchy of contacts or lists or searching more than one address book wanted reorganise by copying but only contacts with email address can be copied, any contact without an email address cannot be copied to another address book. 

Reproducible: Always

Steps to Reproduce:
1.move to an address contact with no email address (just fax/phone etc)
2.try to copy
3.says it copies but it doesn't :-(
Actual Results:  
Doesn't copy

Expected Results:  
Should copy across

Seems to be a silly bug :-(
Copying cards between address books should work ok (even if they have no email address), copying cards without an email address to a list won't work because mailing lists don't support cards without addresses (there are other bugs raised on that problem).

Comment 2

11 years ago
I guess that's bug 318364.
(Reporter)

Comment 3

11 years ago
OK, after reading Mark's comment I guess the bug should be changed to indicate that a message should be returned to the user saying: "the card has been copied to the base address book but could NOT be copied to the 'email list' because there was no valid email address".

I have dropped the severity to minor to indicate that this is perhaps a "user dialog" issue rather than a bug.

thanks
Severity: normal → minor

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 248786
You need to log in before you can comment on or make changes to this bug.