Opening link in new window, then clicking picture in the new window results in picture being displayed but Back Button remains disabled.

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: hjohn, Unassigned)

Tracking

2.0 Branch
x86
Windows Server 2003
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

Opening a link by right clicking on it and selecting "Open in New Window" causes the back button to malfunction somehow.  When you click something in the new window that doesn't open a new tab or window, the Back Button will remain disabled.  This means you cannot return to the article you were viewing, which is extremely annoying.

This bug ONLY occurs when you open the link in a new window.  If you open it in a new tab, there's no problem.  If you copy and paste the URL in a new window, there's no problem either.

I'm happy to supply more information to get this problem fixed.


Reproducible: Always

Steps to Reproduce:
1. Go to the supplied webpage, http://linux.slashdot.org/linux/07/01/05/0612213.shtml (just an example, it happens with many pages)

2. Right-click on the link in the summary ("throws light on some of the features"), and select "Open in New Window".  A new window appears on my system with just a single tab visible, as expected.

3. In this new window, click on one of the pictures in the article to see the picture full-size.  Notice that no new tab is created, nor is a new window created.  Notice also that the Back Button is disabled still ... there is no way to return to the article that had the picture embedded in it.
Actual Results:  
The back button is disabled.

Expected Results:  
The back button should be enabled, so I can return to the article.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

I can't reproduce this in a new profile; in all cases I see a green enabled back button.
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204
> Firefox/2.0.0.1
> 
> I can't reproduce this in a new profile; in all cases I see a green enabled
> back button.
 
I am unable to reproduce it in a new profile as well.  My current profile isn't very old, at most a month.  I will try and find out what is causing this problem to appear.  I can still reproduce it without any problem in my current profile. 
I can confirm this with my current profile. Creating a new profile does fix the issue but that's not acceptable solution as I can't loose all my configurations.

This also affects Reload button, which is enabled but doesn't do anything on the new window. After clicking a link on the page the Reload button works again but Back button gets enabled only after clicking second link. Also the top level and context menu Back selection is affected. Workaround is to use History menu as the previous page does get recorded in the list and can be used to navigate back.

I can also reproduce this by having Firefox open and opening an external link. If Firefox is not running then the new window works as expected. I have Tabs -> New pages should be opened in set to "a new window". It doesn't matter what URL is opened.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 2.0 Branch
Not an issue with Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.4pre) Gecko/20070510 BonEcho/2.0.0.4pre
I hunted for the cause of this problem and turns out that disabling v0.8.3.9 of Html Validator add-on (https://addons.mozilla.org/en-US/firefox/addon/249) fixes this issue for me. I have sent author of the add-on (Marc Gueury) a note about this.
Please don't confirm "bugs" caused by extensions.
Problems caused by code in extensions are INVALID, unless the author of the extension can't work around them. In that case the author himself will file a bug and discuss about the issue.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Reporter, do you also have installed this add-on? If not than you should also do a test by starting Firefox in Safe-Mode. If it still happens for you with all extensions disabled we should reopen this bug. Otherwise it will be an add-on problem and invalid.

Comment 8

11 years ago
I am the author of the extension HTML Validator. 
 
I can confirm that this bug happens when the extension is installed.
But the problem is a bug in XUL and the cause of the problem is a little crazy, when I change a image of an icon in the status bar, the back button misbehave...

Anyway, I need to log a clear bug for XUL about this.

Marc

Comment 9

11 years ago
I logged a bug 380619 on Firefox for this.
(Reporter)

Comment 10

11 years ago
I reported this originally, unfortunately (even though I'm still using the same profile) I can't reproduce the bug anymore.  I've never been able to isolate the problem or reproduce it with a new profile.  I never had the HTML Validator extension installed though, but perhaps it is caused by other plug-ins as well (I only had 3 installed at the time, Download Sort, Refresh Blocker and Flashblock).

Sorry that I can't be of more help.
(In reply to comment #10)
> profile) I can't reproduce the bug anymore.  I've never been able to isolate
> the problem or reproduce it with a new profile.  I never had the HTML Validator
> extension installed though, but perhaps it is caused by other plug-ins as well
> (I only had 3 installed at the time, Download Sort, Refresh Blocker and
> Flashblock).

If you ever can reproduce this issue again feel free to reopen that bug. But deactive all add-ons first and test again. You can also use the safe mode for that (start Fx with the command line parameter -safe-mode).
You need to log in before you can comment on or make changes to this bug.