[xml] attachment element should include size

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
Bug Import/Export & Moving
--
enhancement
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Robert Elves, Assigned: Frédéric Buclin)

Tracking

2.23.3
Bugzilla 3.0
Bug Flags:
approval +

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

When using show_bug.cgi with ctype=xml the size of the attachment isn't included in the xml. The size should also be included when the xml is retrieved using excludefield=attachmentdata. 

Reproducible: Always

Steps to Reproduce:
1.View bug with an attachment using ctype=xml
2.
3.
Actual Results:  
attachment element doesn't include size (although this information is available in the html)

Expected Results:  
size should be included in the output xml
(Assignee)

Comment 1

11 years ago
Created attachment 250607 [details] [diff] [review]
patch, v1
Assignee: create-and-change → LpSolit
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #250607 - Flags: review?(ghendricks)
(Assignee)

Updated

11 years ago
Severity: normal → enhancement
Component: Creating/Changing Bugs → Bug Import/Export & Moving
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → 2.23.3

Comment 2

11 years ago
Comment on attachment 250607 [details] [diff] [review]
patch, v1

>Index: template/en/default/bug/show.xml.tmpl

This works correctly.

However, bugzilla.dtd needs to be updated as well.
Attachment #250607 - Flags: review?(ghendricks) → review-
(Assignee)

Comment 3

11 years ago
Created attachment 250714 [details] [diff] [review]
patch, v2

Yup, right
Attachment #250607 - Attachment is obsolete: true
Attachment #250714 - Flags: review?(bugzilla-mozilla)
(Assignee)

Comment 4

11 years ago
Created attachment 250715 [details] [diff] [review]
patch, v2.1

grrr...
Attachment #250714 - Attachment is obsolete: true
Attachment #250715 - Flags: review?(bugzilla-mozilla)
Attachment #250714 - Flags: review?(bugzilla-mozilla)

Updated

11 years ago
Attachment #250715 - Flags: review?(bugzilla-mozilla) → review+
(Assignee)

Updated

11 years ago
Flags: approval?
Target Milestone: --- → Bugzilla 3.0
Flags: approval? → approval+
(Assignee)

Comment 5

11 years ago
Checking in bugzilla.dtd;
/cvsroot/mozilla/webtools/bugzilla/bugzilla.dtd,v  <--  bugzilla.dtd
new revision: 1.15; previous revision: 1.14
done
Checking in template/en/default/bug/show.xml.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/show.xml.tmpl,v  <--  show.xml.tmpl
new revision: 1.19; previous revision: 1.18
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

11 years ago
Excellent! Thanks for getting this into 3.0.
You need to log in before you can comment on or make changes to this bug.