If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

-ProfileManager ignored on second startup

RESOLVED DUPLICATE of bug 362355

Status

()

Toolkit
Startup and Profile System
RESOLVED DUPLICATE of bug 362355
11 years ago
9 years ago

People

(Reporter: a_geek, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.9) Gecko/20061206 Firefox/1.5.0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.9) Gecko/20061206 Firefox/1.5.0.9

Hello,
I run one copy of Firefox and would like to run a second with a different profile. I already have a number of different profiles, so I tried to start Firefox by using these incantations:

$ firefox -ProfileManager
$ firefox -ProfileManager -no-remote
$ firefox -ProfileManager --no-remote

But whatever I tried, it would not come up with the profile manager but instead load the home page. Also, there was no individual session, but it was just another window of the already-running session.

What gives?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



I searched mozilla.org and mozilla.com as well as the Firefox installation and its online help for how to run a separate session to no avail. NB: Every web developer (at least!) needs this functionality.
-no-remote wasn't supported until 2.0, for 1.5.0.x you need to |set MOZ_NO_REMOTE=1| first.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 362355
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.