Clicking content area of Firefox window doesn't always raise window

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
12 years ago
11 years ago

People

(Reporter: sharding, Unassigned)

Tracking

2.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

When Firefox is not the front application (with focus), clicking in the content area of a Firefox window sometimes does not bring Firefox to the front and give it focus. Instead, it occasionally sends Firefox to the *back*, behind all other open windows. This seems to be triggered by first sending the front application's window to the dock.

Reproducible: Sometimes

Steps to Reproduce:
1. Launch terminal and leave at least one window open and up (not in the dock).
2. Launch Firefox and load any web page (e.g. CNN.com). Ensure that the Firefox window is in front of the Terminal window (this is not necessary to reproduce the problem, but it makes it easier to see what's happening).
3. Launch TextEdit.
4. Send the TextEdit window to the Dock by clicking the yellow button in the menubar.
5. Click inside of the content area of the Firefox window.
Actual Results:  
1. TextEdit remains the active application, with focus.
2. The terminal window comes up in front of the Firefox window.

Expected Results:  
1. Firefox becomes the active application and comes to the front, in front of all other open windows.

This seems like it could be an OS/WindowServer issue, but Firefox is the only application that I've ever seen exhibit this behavior.

This is 100% reproducable for me if I first minimize/dock an application and then click in the Firefox content area. If I *don't* minimize/dock the active application, the problem does not happen. If I click the titlebar instead of the content area, the problem does not happen (regardless of whether I've minimized an app or not).

I think this started with Firefox 2, but I'm not positive. I've definitely been noticing it a lot more lately.

Comment 1

11 years ago
Reporter, are you still able to reproduce with a more recent build of Firefox? If not, could you please resolve this bug WORKSFORME? Thanks.
Whiteboard: CLOSEME 08/09
Sean, I can't reproduce using Firefox 2.0.0.6 on Mac OS X 10.4.10. Can you still reproduce this? If not, please close this bug as WORKSFORME. Otherwise, try with a new profile or even with a new Mac OS X user account.

http://kb.mozillazine.org/Profile_Manager
Whiteboard: CLOSEME 08/09 → CLOSEME 08/30
Version: unspecified → 2.0 Branch
(Reporter)

Comment 3

11 years ago
I can't repro this anymore either. Closing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Updated

11 years ago
Whiteboard: CLOSEME 08/30
You need to log in before you can comment on or make changes to this bug.