click on URL, does not open in FF in new tab, nor in new window

RESOLVED INVALID

Status

RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: ray, Assigned: rginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

The content from the link that you clicked in the chat replaces the content of the front-most tab or window in the Firefox browser window, no matter how the preferences are set.

Reproducible: Always

Steps to Reproduce:
1. Confirm that Firefox preferences are set: click on "Tabs" in preferences and click on the "New pages are opened in (X) a new tab" option.
2. open a Firefox window with two tabs of different content
3. enter some chat and wait for a http URL
4. click on the URL
5. If the preferences is set to "New pages open in (x) a new window", do the same
Actual Results:  
The content from the link that you clicked in the chat replaces the content of the front-most tab or window in the Firefox browser window.

Expected Results:  
If I have my Firefox preferences set to "New pages open in (x) a new window", and I click on an HTTP link in a Chatzilla chat, I expect the content of the link to go into a new Firefox window, and not replace the front-most window.

If I have my Firefox preferences set to "New pages open in (x) a new tab", and I click on an HTTP link in a Chatzilla chat, I expect the content of the link to go into a new Firefox tab in the front-most window, and not replace the front-most tab in the front-most window.

Comment 1

12 years ago
ChatZilla has its own preferences for opening links in tabs, which means you get better control if you use those, than if we would depend on Firefox's preferences. Which is why I'm marking this invalid - it's not a bug, you should change your ChatZilla preferences (ChatZilla > Preferences > Global Settings > Global > Links)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

12 years ago
Ah. That worked.

FYI, since there is a top-level "Chatzilla" menu in the menu bar (on a Mac), I expected the Preferences to be under the "Chatzilla" menu item. I did not expect that it would go under the Firefox menu. I am not sure that the current menu setup is correct. Coming from a Mac background, it certainly is confusing.

I am able to change my preference, though. Thanx.
You need to log in before you can comment on or make changes to this bug.