Import ICS feeds from the OS

RESOLVED DUPLICATE of bug 549199

Status

Calendar
Import and Export
--
enhancement
RESOLVED DUPLICATE of bug 549199
12 years ago
8 years ago

People

(Reporter: matthaeus123, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
Sunbird should be able to accept ICS feeds that are exported from Firefox. ICS feeds should be handled the same way that Firefox works with RSS feeds and exporting those feeds to a RSS reader.
(Reporter)

Updated

12 years ago
Blocks: 366392
(Reporter)

Updated

12 years ago
No longer blocks: 366392
Depends on: 279569, 366392
(Reporter)

Comment 1

12 years ago
Would this have to be registered in the Windows registry to work properly?
I believe we need to register Sunbird as a handler of .ics files in order for this to work.

CCing rob_strong on this to get the whole scoop.
Yes, Sunbird should register as an .ics handler and should have the option to be set as the default ics handler. It should also work with any request to open an ics file and not just from Firefox.
Summary: Import ICS feeds from Firefox → Import ICS feeds from the OS

Comment 4

11 years ago
dupe of bug 362285?
Hardware: PC → All
Target Milestone: Future → ---
Version: Trunk → unspecified
Voting for WONTFIX!
No longer depends on: 366392
Whiteboard: [needs decision]

Comment 6

9 years ago
Martin, why wontfix?
(In reply to comment #6)
> Martin, why wontfix?

Basically, I'm not sure sure what the difference to a simple iCalendar file is, and how a direct integration with Firefox should work (also see WONTFIX of bug 366392). This bug is more an unspecific request which has to be solved by other already filed bugs, more precisely bug 352566, bug 359807 and bug 362285. These bugs cover the registration of the webcal protocol with Windows, the addition of a command line switch to start Thunderbird with the calendar tab opened, and the registration of Lightning/Sunbird as the default calendar for Windows. We may need an additional bug for the registration of the file extension *.ics with Windows.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 549199
Whiteboard: [needs decision]
You need to log in before you can comment on or make changes to this bug.