Crash when opening new URLs

RESOLVED DUPLICATE of bug 366500

Status

()

Firefox
Disability Access
--
critical
RESOLVED DUPLICATE of bug 366500
11 years ago
11 years ago

People

(Reporter: Willie Walker, Unassigned)

Tracking

({access})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a2pre) Gecko/20070108 Minefield/3.0a2pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a2pre) Gecko/20070108 Minefield/3.0a2pre

I see a relatively consistent, but still somewhat intermittent, crash when I go from one URL to another in Firefox.  The problem seems to be related to accessibility and happens regardless if I run an assistive technology or not.

Here's a typical incident and stack trace I get when this happens (several times an hour):

http://talkback-public.mozilla.org/search/start.jsp?search=2&type=iid&id=TB28179697Z

Stack Signature	 0x00000061 e9e03e85
Product ID	FirefoxTrunk
Build ID	2007010804
Trigger Time	2007-01-09 05:32:27.0
Platform	LinuxIntel
Operating System	Linux 2.6.17-10-generic
Module	
URL visited	
User Comments	
Since Last Crash	5 sec
Total Uptime	7 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.	N/A
Stack Trace 	
0x00000061
nsQueryInterface::operator()
nsCOMPtr_base::assign_from_qi()
nsAccessible::Shutdown()
nsHTMLTextFieldAccessible::Shutdown()
nsAccessNode::ClearCacheEntry()
nsBaseHashtable<nsVoidHashKey, nsCOMPtr<nsIAccessNode>, nsIAccessNode*>::s_EnumStub()
PL_DHashTableEnumerate()
nsAccessNode::ClearCache()
nsDocAccessible::Shutdown()
nsDocAccessible::Destroy()
nsRootAccessible::HandleEventWithTarget()
nsRootAccessibleWrap::HandleEventWithTarget()
nsRootAccessible::HandleEvent()
nsEventListenerManager::HandleEventSubType()
nsEventListenerManager::HandleEvent()
nsEventTargetChainItem::HandleEvent()
nsEventTargetChainItem::HandleEventTargetChain()
nsEventDispatcher::Dispatch()
nsDocument::DispatchEventToWindow()
nsDocument::OnPageHide()
DocumentViewerImpl::PageHide()
nsDocShell::FirePageHideNotification()
nsDocShell::CreateContentViewer()
nsDSURIContentListener::DoContent()
nsDocumentOpenInfo::TryContentListener()
nsDocumentOpenInfo::DispatchContent()
nsDocumentOpenInfo::OnStartRequest()
nsHttpChannel::CallOnStartRequest()
nsHttpChannel::ProcessNormal()
nsHttpChannel::ProcessResponse()
nsHttpChannel::OnStartRequest()
nsInputStreamPump::OnStateStart()
nsInputStreamPump::OnInputStreamReady()
nsInputStreamReadyEvent::Run()
nsThread::ProcessNextEvent()
NS_ProcessNextEvent_P()
nsBaseAppShell::Run()
nsAppStartup::Run()
XRE_main()
main()
libc.so.6 + 0x158cc (0xb73868cc)


Reproducible: Always

Steps to Reproduce:
1. Enable a11y.
2. Run Firefox.
3. Move to a different page 
Actual Results:  
Crashes periodically (several times an hour)

Expected Results:  
Should never crash.
(Reporter)

Updated

11 years ago
Keywords: access
(Reporter)

Comment 1

11 years ago
See also bug 366434 (https://bugzilla.mozilla.org/show_bug.cgi?id=366434) - it may be the source of this crasher.
(Reporter)

Comment 2

11 years ago
Sorry...in observing another bug, I noticed someone replied to it talking about my typo in this bug.  I meant bug 366435 (https://bugzilla.mozilla.org/show_bug.cgi?id=366435).

Comment 3

11 years ago
same core stack with bug 366500, and they're both about pagehide.
mark as duplicate
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 366500
You need to log in before you can comment on or make changes to this bug.