If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Spell check suggestion doesn't display when opening contextual menu via the Windows application key

VERIFIED DUPLICATE of bug 346930

Status

()

Firefox
Menus
VERIFIED DUPLICATE of bug 346930
11 years ago
10 years ago

People

(Reporter: Pierre Goiffon, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1 Mnenhy/0.7.4.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1 Mnenhy/0.7.4.0

When opening the contextual menu with a right click above an incorrected spelled word, the menu is first filled at its top with suggestion from the current dictionnary. If the menu is opened with the windows application key on the keyboard while the caret is located in an incorrected spelled word, no suggestions are presented on top of the contextuel menu.

Reproducible: Always

Steps to Reproduce:
1. opens a webpage containing a form with a textarea
2. right click in the text area, check the "spell check this field" option
3. right click again and choose the english dictionary
4. type in the textarea some text with incorrect spelling like "Firefox is so coooool"
5. the "coooool" word is underlined. Place the caret in that word, press the windows application key to open the contextual menu : no suggestions are present on top of the menu
6. press escape to close the menu, right click on the "coooool" word : suggestions are present on top of the menu
Actual Results:  
Spell suggestions only appears when the context menu is opened with a mouse right click

Expected Results:  
Spell suggestions should always appear
Component: Form Manager → Menus
QA Contact: form.manager → menus
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 346930
V.Duplicate
Status: RESOLVED → VERIFIED
Version: unspecified → 2.0 Branch
You need to log in before you can comment on or make changes to this bug.