Make back and forward history buttons default toolbar items

RESOLVED FIXED in Thunderbird2.0

Status

Thunderbird
General
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Scott MacGregor, Assigned: Scott MacGregor)

Tracking

({fixed1.8.1.2})

Thunderbird2.0
fixed1.8.1.2
Bug Flags:
blocking-thunderbird2 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

11 years ago
Our toolbar is already full at low resolutions :(

But we might still want to think about adding the back/forward history buttons as default toolbar buttons.

This makes this new feature more discoverable.
Flags: blocking-thunderbird2+

Updated

11 years ago
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 1

11 years ago
I just confirmed that with a new profile, and our out of the box default window size, the back and forward buttons don't fit in the toolbar. most of the quick search box gets truncated.

We could look at increasing our default window size, but that's not going to help lower resolution monitors.

Or we could look at replacing the print and stop buttons with go forward / go back in the default set.

I'm pretty open to ditching the stop button, I can't think of the last time I used that button, not as confident about print though.

Comment 2

11 years ago
yeah, the stop button could go, but a lot of people who use the print button would probably be confused if it wasn't there...
(Assignee)

Comment 3

11 years ago
Created attachment 252400 [details] [diff] [review]
a possible fix

* Remove the stop button
* Add the print button to the Tag / Delete /Junk buttons. The rational here is that  all of these actions are things you perform directly on a message. So we've got activities: Get mail / Write / Address Book.  Reply actions: Reply / reply all / Forward. message actions: Tag / Junk / Delete and now Print. And navigation actions: Back / Forward.

Even with losing the stop button, we still don't have enough room under certain resolutions. Here's a low down:

* 800 x 600 doesn't even come close to fitting. But our current default toolbar set doesn't quite fit either. Note: at 800 x 600, the window opens in a maximized state.
* 1024 x 768 Normal Fonts: doesn't quite fit.
* 1024 x 768 Large Fonts: doesn't fit.
* Higher resolutions at both normal and large fonts seem to work fine.

So the next thing I did was go after the 1024x768 normal font case. 800 x 600 is a lost cause I think. 

For high resolution displays (> 800 x 600), we currently open up the first 3-pane window using 80% of the available screen width. By bumping this up to 90% I was able to make the initial window wide enough for this default configuration. Large fonts with 1024x768 almos make it with a very small amount of clipping on the search box. I'd rather not use an even higher percentage of the screen width just to fix that specific case. 

Alternatively, I could explore looking for a screen height of 768, using 95% for just for that resolution, leaving the rest of the high resolutions alone at their existing 80% level.
(Assignee)

Comment 4

11 years ago
Created attachment 253797 [details]
both small and large fonts now fit with the new window sizes

I made my patch work such that a width of 1024 uses 95% of the available screen width instead of 80% this allows the toolbar to fit with no stop button and print grouped with mark/junk/delete for both normal and large fonts @ 1024 x 768.
(Assignee)

Comment 5

11 years ago
Created attachment 253798 [details] [diff] [review]
updated fix

This improved patch works for 1024x768 at normal and large fonts by using 95% of the available width for that screen width and the standard 80% for higher resolutions. 

Drop the stop button, move the print button and add back and forward navigation buttons.

Beta users will not see this in their default toolbar because we've already reset the toolbar to the default set when we overhauled the search widgets. New users coming from 1.5 will see these new buttons in their toolbar by default though.
Attachment #252400 - Attachment is obsolete: true
Attachment #253798 - Flags: superreview?(bienvenu)

Comment 6

11 years ago
Comment on attachment 253798 [details] [diff] [review]
updated fix

nice, thx, Scott!
Attachment #253798 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1.2
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.