The default bug view has changed. See this FAQ.

Unable to save a saved search when no there is no folder pane selection

RESOLVED FIXED

Status

MailNews Core
Backend
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: Scott MacGregor, Assigned: Andrew Schultz)

Tracking

({fixed-seamonkey1.1.1, verified1.8.1.2})

Trunk
fixed-seamonkey1.1.1, verified1.8.1.2
Bug Flags:
blocking-thunderbird2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.56 KB, patch
Scott MacGregor
: review+
Scott MacGregor
: superreview+
Scott MacGregor
: approval-thunderbird2+
Details | Diff | Splinter Review
(Reporter)

Description

10 years ago
1) Start up Thunderbird
2) Change the folder view and then go back to the original view
3) Note that we have lost folder pane selection and no longer have a selected folder (this is a separate bug)
4) File / New / Saved Search

try to click on the Choose button to choose which folders to search. Try to click ok to save the search. Note that neither of these options work because the RDF uri for the folder argument we pass into this dialog is empty.

Should be easy to bullet proof around (maybe choosing the default account's inbox or requiring the user to go through the choose button). Maybe magnus is interested in taking a look.
Flags: blocking-thunderbird2+

Comment 1

10 years ago
Error Console after clicking choose:
==========
Error: folder has no properties
Source File: chrome://messenger/content/virtualFolderProperties.js
Line: 249
==========

Updated

10 years ago
Duplicate of this bug: 367660

Updated

10 years ago
Component: Mail Window Front End → MailNews: Backend
OS: Windows XP → All
Product: Thunderbird → Core
Hardware: PC → All
Version: 2.0 → Trunk
(Assignee)

Comment 3

10 years ago
Created attachment 252568 [details] [diff] [review]
drop serverURI

virtualFolderListDialog doesn't use serverURI, so this doesn't need to be bother trying to figure out what it should be.
Assignee: mscott → ajschult
Status: NEW → ASSIGNED
Attachment #252568 - Flags: superreview?(mscott)
Attachment #252568 - Flags: review?(mscott)
(Reporter)

Comment 4

10 years ago
Comment on attachment 252568 [details] [diff] [review]
drop serverURI

Thanks for the patch Andrew!
Attachment #252568 - Flags: superreview?(mscott)
Attachment #252568 - Flags: superreview+
Attachment #252568 - Flags: review?(mscott)
Attachment #252568 - Flags: review+
Attachment #252568 - Flags: approval-thunderbird2+
(Assignee)

Updated

10 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: fixed-seamonkey1.1.1, fixed1.8.1.2
Resolution: --- → FIXED
Verfied fixed for 1.8.1.2 on Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.2pre) Gecko/20070206 Thunderbird/2.0pre Mnenhy/0.7.4.10002 ID:2007020604
Keywords: fixed1.8.1.2 → verified1.8.1.2
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.