[async] deleting renamed first event of a rule changed the title of all events

VERIFIED FIXED

Status

Calendar
Provider: WCAP
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: Andreas Treumann, Assigned: Andreas Treumann)

Tracking

Lightning 0.3
Bug Flags:
in-litmus ?

Details

(Assignee)

Description

11 years ago
REPRODUCTION:
=============

- create a new event, name it 'test', create a recurrence rule (e.g. daily, 5 times)
- select the first event of this rule
- open the edit dialog and choose 'this occurrence only'
- rename this event, e. g. '123', and save this
- now delete this event

RESULT:
=======

- all other events of the recurrence changed now there title to '123'  

EXPECTED RESULT:
================

- the events should not change there title

REPRODUCIBLE:
=============

- always

This happens only with WCAP calendars. I can't reproduce this bug with the m6 build.

Comment 1

11 years ago
This is a server bug I will most probably file against.
I fixed that working around the problem by writing all of the parent's data when the recurrence info is modified (which actually took place here: an EXDATE is added).
Assignee: daniel.boelzle → andreas.treumann

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Whiteboard: [litmus testcase wanted]
(Assignee)

Comment 2

11 years ago
I checked this in the latest build, bug is fixed.
Status: RESOLVED → VERIFIED

Updated

11 years ago
Flags: in-litmus?
Whiteboard: [litmus testcase wanted]
You need to log in before you can comment on or make changes to this bug.