innerHTML should not give back   literally

RESOLVED INVALID

Status

()

RESOLVED INVALID
12 years ago
11 years ago

People

(Reporter: annevk, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
When you use an entity like   Mozilla gives that back literally when using innerHTML instead of converting it to the character as expected. See also:

  http://www.whatwg.org/specs/web-apps/current-work/#innerhtml
(Reporter)

Comment 1

12 years ago
This might be caused by bug 165686.
(Reporter)

Comment 2

11 years ago
Makes more sense to change HTML5 to require this actually, imo.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.