Closed Bug 366579 Opened 13 years ago Closed 11 years ago

reftest: make lcheck should create a special profile for the test run

Categories

(Testing :: Reftest, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 468913

People

(Reporter: asqueella, Unassigned)

References

()

Details

Just making sure there's a bug filed for this.

reftest makefile currently uses the user's profile to run the tests:
http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/layout/reftests/Makefile.in&rev=1.2&mark=52#51

This is clearly undesirable for automated testing, it should do something like what mochitest does (i.e. create a new profile with some pre-set prefs and use it for the session running the tests). Maybe it could be even shared across the various tools that run the tests.
Status: NEW → RESOLVED
Closed: 11 years ago
Component: Testing → Reftest
Product: Core → Testing
QA Contact: testing → reftest
Resolution: --- → DUPLICATE
Version: Trunk → unspecified
Duplicate of bug: 468913
You need to log in before you can comment on or make changes to this bug.