Session restore doesn't restore tabs that were not completely loaded when Firefox closed

RESOLVED DUPLICATE of bug 367605

Status

()

--
major
RESOLVED DUPLICATE of bug 367605
12 years ago
11 years ago

People

(Reporter: alexwhite777, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

If Firefox is configured to "Show my windows and tabs from last time", and if Firefox is opened and some seconds later closed, but before all the tabs are completely loaded (since seems FF load tabs one by one, sequentially), then, when it's opened again, it shows all the tabs but those that wasn't get to load completely are "(Untitled)", empty tab.
It's more easy to see this if you were working on something like 20 tabs open and with URLs loaded.
The only way to don't have this problem is to wait aaaall the tabs get completely loaded before you close Firefox again.

Reproducible: Always

Steps to Reproduce:
1. Configure Firefox to "Show my windows and tabs from last time", on Options, Main.
2. Open some tabs (for example, 20 tabs), all with URLs loaded in each one.
3. Close Firefox cleanly (answering Yes to the "Confirm close" dialog box if necessary).
4. Open Firefox and then close it cleanly again (if 20 tabs were opened, you can take a few seconds).
5. Open Firefox.
Actual Results:  
Only the tabs that reached to load are going to be loaded, the first ones. The rest of the tabs empty ("(Untitled)").

Expected Results:  
Open all the tabs, even those that did not reach to load on the last session.

Theme I'm using: iFox v2.4.2 (the last version)

about:buildconfig

Build platform
target
i586-pc-msvc

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-official-branding --enable-optimize --disable-debug --disable-tests --enable-static --disable-shared --enable-svg --enable-canvas --enable-update-packaging
Does this happen in firefox's safemode?
http://kb.mozillazine.org/Safe_mode
(Reporter)

Comment 2

12 years ago
Yes, this bug also happen on firefox's safemode.

One more thing to the bug report (to the "Actual Results"): Not only the first tabs are loaded, also the one that have the focus on the last closed session.

Comment 3

11 years ago
I think this is related to the partial restore after crash while restoring.

Often, my system crashes when numerous (20+) tabs were opened, some to URL with pdf files

On restart, only those tabs that had finished reloading at the time of the crash are filled.  FF remembers the number of total tabs but many are opened to blank when this happens.
(Reporter)

Comment 4

11 years ago
That is not necessary true. As it says in the title, if you close Firefox cleanly (not a crash), when not all tabs are completely loaded, the next time you open Firefox the loaded tabs will load, and those one that didn´t will be blank tabs.

Comment 5

11 years ago
Moving this to the right component + resummarizing.
Component: Tabbed Browser → Session Restore
QA Contact: tabbed.browser → session.restore
Summary: Firefox don't "Show my windows and tabs from last time" if last time I closed firefox cleanly but before all the tabs are completely loaded. → Session restore doesn't restore tabs that were not completely loaded when Firefox closed

Comment 6

11 years ago
This bug should be fixed since Firefox 2.0.0.8. Please reopen if that's not the case.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 367605
You need to log in before you can comment on or make changes to this bug.