Closed Bug 366636 Opened 13 years ago Closed 13 years ago

Crash on Yahoo Mail Beta with Adblock Plus installed

Categories

(Core :: General, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: fullmetaljacket.xp+bugmail, Unassigned)

References

()

Details

(Keywords: crash, qawanted)

bug# 361709 now wfm on http://us.f513.mail.yahoo.com/ server (18:31 pst)

but crashes when i tried to reply on my inbox email or open email to new tab (tab with yahoo mail beta)

TB28239008X
TB28239055Y

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a2pre) Gecko/20070110 Minefield/3.0a2pre ID:2007011015 [cairo]
Product: Firefox → Core
QA Contact: general → general
how's this depending on bug 361709?
you cant trigger this bug unless bug# 361709 is fixed.

From the talkback ID's it seems Java Liveconnect is involved here:
TB28239055Y
nsInlineFrame::AddInlinePrefWidth  [mozilla\layout\generic\nsinlineframe.cpp, line 345]
nsXBLDocGlobalObject::EnsureScriptEnvironment  [mozilla\content\xbl\src\nsxbldocumentinfo.cpp, line 301]
throw_any_pending_js_error_as_a_java_exception  [mozilla\js\src\liveconnect\jsj_jsobject.c, line 556]
0x02dea118
Severity: major → critical
Summary: Crash on Yahoo Mail Beta - nsInlineFrame::AddInlinePrefWidth → Crash on Yahoo Mail Beta [@ nsInlineFrame::AddInlinePrefWidth]
LiveConnect, really?  Does Yahoo Mail Beta use Java at all?

I suspect that part of the stack trace is bogus.
I can't reproduce. WFM
(In reply to comment #2)
> you cant trigger this bug unless bug# 361709 is fixed.

Still not a technical dependency.
No longer depends on: 361709
(In reply to comment #5)
> I can't reproduce. WFM
> 

thanks for testing.

crashes was caused by an extension (adblock plus specifically).

sorry for the trouble. my mistake.


Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
Given that
1) Yahoo Mail Beta and Adblock Plus are both popular
and
2) The stack trace is scary

I hope this crash gets fixed.  I don't know whether the bug lies in Adblock Plus or in Gecko.
Summary: Crash on Yahoo Mail Beta [@ nsInlineFrame::AddInlinePrefWidth] → Crash on Yahoo Mail Beta with Adblock Plus installed [@ nsInlineFrame::AddInlinePrefWidth]
Well, this is not necessarely an invalid bug, see for instance bug 345857.
Ideally, a minimal testcase that triggers the bug would be helpful here.
Status: RESOLVED → REOPENED
Keywords: qawanted
Resolution: INVALID → ---
while i am trying to create a testcase using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a2pre) Gecko/20070114 Minefield/3.0a2pre ID:2007011416 [cairo]

i cant no longer reproduce crashes [@nsInlineFrame::AddInlinePrefWidth] using same profile.

i now got different stack [@nsTextFrame::PaintAsciiText] using same procedure i initially reported. 
TB28391213X
TB28391160E


again with different stack trace: 
TB28460829W
TB28460753Y

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a2pre) Gecko/20070117 Minefield/3.0a2pre ID:2007011716 [cairo]

Summary: Crash on Yahoo Mail Beta with Adblock Plus installed [@ nsInlineFrame::AddInlinePrefWidth] → Crash on Yahoo Mail Beta with Adblock Plus installed
this now WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070503 Minefield/3.0a5pre ID:2007050318 [cairo]

closing this bug....
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
OS: Windows Vista → Windows XP
Resolution: --- → WORKSFORME
Blocks: abp
You need to log in before you can comment on or make changes to this bug.