Radio button objects contain selectionStart and selectionEnd but throws "uncaught exception" when trying to access them in Javascript

RESOLVED INVALID

Status

()

Core
DOM: Core & HTML
RESOLVED INVALID
11 years ago
8 years ago

People

(Reporter: Allan Jensen, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

On a page where I have some (2) radio buttons Javascript throws an "uncaught exception" when I try to loop through all the properties of either one of the radio button objects. In the loop it exception occured when it got to selectionStart and selectionEnd. If I just skip these two in the loop there are no problems. Secondly, I wonder why at all these two properties exist for radio buttons...

Reproducible: Always

Steps to Reproduce:
1. Go to the URL provided
2. Click the Test button which loops through all the properties of the first radio button
3. All property names are written to the screen and "OK" is added when access didn't fail.
Actual Results:  
Uncaught exception was thrown

Expected Results:  
The loop should complete without any problem.
(Reporter)

Comment 1

11 years ago
Hello?? Anybody seeing this report??

Updated

10 years ago
Component: DOM: Core → DOM: Core & HTML
QA Contact: ian → general
We should throw.

<http://www.whatwg.org/html/#radio-button-state>
<http://www.whatwg.org/html/#textFieldSelection>
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID

Updated

8 years ago
Duplicate of this bug: 474677
You need to log in before you can comment on or make changes to this bug.