Palmsync crashes palm during sync with Thunderbird 2 when prefs.js has multiple entries pointing to personal AB file, worked in 1.5

RESOLVED WONTFIX

Status

MailNews Core Graveyard
Palm Sync
--
critical
RESOLVED WONTFIX
11 years ago
3 years ago

People

(Reporter: jwalzer50, Unassigned)

Tracking

({dataloss, regression})

1.8 Branch
x86
Windows XP
dataloss, regression

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: version 2 beta 1 (20061206)

I have been using Palmsync successfully with TB1.5. I have installed TB2. The conduit no longer works. Hotsync says it is syncing MAB but when the sync is over the data has not been sync'ed & there is no entry in the log for MAB. Mozilla Address Book is visible in HotSync. I tried installing it again (I didn't uninstall it first). I also tried a one-way sync (DT->Palm) which didn't work either.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
Hotsync acted like it sync'ed MAB, but nothing happened.

Updated

11 years ago
Flags: blocking-thunderbird2?
Version: unspecified → 2.0

Comment 1

11 years ago
Gordon, do you also see this?   TB 2 B2 is at ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2.0b2-candidates/rc1

Comment 2

11 years ago
Hi Wayne,

I tested PalmSync with TBird 2 Beta 2 and synchronization did not work confirming jwalzer50s observations.  After PalmSync's installation, the conduit does appear in the Hotsync list of conduits, however, no data is sync'ed during hotsync operations to "synchronize the files".  Then, when setup for "Desktop Overwrites Handheld", all of the Palm's address book entries were erased and I was left with an empty address book on my Palm handheld device.

The bottom line is that PalmSync is not functional with TBird 2 Beta 2 and that there is the potential for data loss when setup for "Desktop Overwrites Handheld".

In my tests I used the most recent version of PalmSync (that works fine with TBird 1.5.0.9) and a Palm Treo 700p.

Comment 3

11 years ago
Scott, please note request for blocking 2.0.
confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

11 years ago
reminder to self to check any new .xpi for backward compatibility with TB 1.5.

Comment 5

11 years ago
bumping to critical based on comment 2, with ""Desktop Overwrites Handheld", all of the Palm's address book entries were erased"
Severity: major → critical
Keywords: dataloss

Comment 6

11 years ago
This might turn into a meta bug.  Many issues still need to be addressed. And an early question - Do the issues below (both in general and specific to Thunderbird 2) also affect Seamonkey 1.x, 1.1.1?

Regarding the palm being wiped in comment 2, a) review docs so people get the correct xpi to install, b) retest final xpi for correct version controls, and c) improve conduit to ensure it is working properly with AB before wiping out the palm (probably not essential to this release).

Incomplete testing thus far with a new extension/set of dlls built and provided by bienvenu no longer fails as reported up til now, i.e. it syncs and installs. But...

One major sync bug emerged, coincidentally with jwalzer's address book. When prefs.js contains multiple ABs pointing to the same .mab file then palmsync dutifully syncs the .mab multiple times. filing a new bug. This problem did not manifest itself in TB 1.5 using the same prefs.js/ABs. Probable cause is Bug 331557. 

The bug mentioned above is a big one, was only tested as DT>HH, and underscores there may be other undetected fallout from changes from these
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=mozilla%2Fmailnews%2Fextensions%2Fpalmsync&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-12-01&maxdate=2007-03-20&cvsroot=%2Fcvsroot
or elsewhere. The effect of unusual or corrupted AB profiles in prefs.js should also be considered.

Also, testing and documentation needed regarding extensions and profiles and releases of thunderbird.  Some starting points:
* reliability of install/uninstall (should not be affected)
* will automated version update via extension manager work, and should it be used?
* should extension versions be served via add-ons website?
* need to test and document an area of concern that palmsync is still not the same as other extensions, in that if palmsync is installed in profile A and thunderbird is started with profile B, then palmsync will still sync - using AB data from profile B.
* what happens if user starts backlevel version of thunderbird, eg installs palmsync 2.0 in thunderbird 2.0, then starts TB 1.5 and syncs?

Questions: 
* Should 1.5 version xpi be retrofitted and reissued with the new extension wrapping and version control so that it can only be installed on a 1.5 system?
* Can *running* conduit, during sync, query thunderbird to determine it is a compatible version?

Finally, several more testers are needed!  And time is short.
Flags: blocking-thunderbird2?

Comment 7

10 years ago
Any update on this issue?
I can do testing if needed. Contact me for more info about my setup.

QA Contact: build → build-config

Comment 8

10 years ago
(In reply to comment #7)
> Any update on this issue?
> I can do testing if needed. Contact me for more info about my setup.

Matt, treo is known to work for some. see http://forums.mozillazine.org/viewtopic.php?p=3202311 and http://kb.mozillazine.org/PalmSync_-_Thunderbird - comment in the forum if you have difficulty.


Joel was very helpful and we exchanged logs and some modest analysis ensued. It is curious that this worked in 1.5 (1.8.0 branch) and fails in 2.0 (1.8.1 branch). Don't know what caused the regression.

My conclusion is multiple old entries (ABs) in prefs.js have URIs that point to the (same) current personal AB file. These old ABs don't appear in the address book because they were deleted, but parts of the definition still exist in prefs.js - and because palmsync walks prefs.js for AB entries we get into this problem. This phenomena is seen in other problem reports.

From the top of Joel's log we see

a) sync=3 is set, which is PC overwrites HH
b) it is somehow detecting "Personal" 14 times.  :(

Moz AB[1] category index/synced=-1/0, name= 'Personal Address Book',
Moz AB[2] category index/synced=-1/0, name= 'Personal Address Book',
Moz AB[3] category index/synced=-1/0, name= 'Personal Address Book',
Moz AB[4] category index/synced=-1/0, name= 'Personal Address Book',
Moz AB[5] category index/synced=-1/0, name= 'Personal Address Book',
Moz AB[6] category index/synced=-1/0, name= 'Personal Address Book',
Moz AB[7] category index/synced=-1/0, name= 'Personal Address Book',
Moz AB[8] category index/synced=-1/0, name= 'Personal Address Book',
Moz AB[10] category index/synced=-1/0, name= 'Personal Address Book',
Moz AB[11] category index/synced=-1/0, name= 'Personal Address Book',
Moz AB[14] category index/synced=-1/0, name= 'Personal Address Book',
Moz AB[15] category index/synced=-1/0, name= 'Personal Address Book',
Moz AB[16] category index/synced=-1/0, name= 'Personal Address Book',
Moz AB[17] category index/synced=-1/0, name= 'Personal Address Book',

c) and then it goes on to sync it 14 times, giving you 14*1184 =16,576 AB entries - at which point the treo crash - probably out of space.

Perhaps Thunderbird 3 AB refactoring will help get rid of these issues. Or if someone gets time I think it is possible to fix the problem in palmsync for thunderbird v2, but it's beyond my time and expertise at the moment. 

Note to self - attach Joel's log if there is nothing sensitive. (mail folder palmsync/waltzer)
Note: Joel has since moved from windows to mac, so we no longer have him for testing
Assignee: mscott → nobody
Component: Build Config → Build Config
Keywords: regression
Product: Thunderbird → Core
QA Contact: build-config → build-config
Summary: Palmsync doesn't work in TB 2 B 1 → Palmsync doesn't work in Thunderbird 2 when prefs.js has multiple entries pointing to personal AB file, worked in 1.5
Version: 2.0 → 1.8 Branch

Updated

10 years ago
Assignee: nobody → bienvenu
Component: Build Config → MailNews: Palm Sync
QA Contact: build-config → vseerror
Summary: Palmsync doesn't work in Thunderbird 2 when prefs.js has multiple entries pointing to personal AB file, worked in 1.5 → Palmsync crashes palm during sync with Thunderbird 2 when prefs.js has multiple entries pointing to personal AB file, worked in 1.5
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core
QA Contact: vseerror → palm-sync

Updated

9 years ago
Component: Palm Sync → Palm Sync
Product: MailNews Core → MailNews Core Graveyard

Updated

9 years ago
Assignee: bienvenu → nobody
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.