pressing the command (ie. apple) key in Yahoo's finance site causes you to jump up the page

RESOLVED DUPLICATE of bug 374700

Status

()

RESOLVED DUPLICATE of bug 374700
12 years ago
12 years ago

People

(Reporter: paulmisc, Unassigned)

Tracking

({qawanted, regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

For the Yahoo finance site, it seems that when you first cmd+click a link, it works (ie. it opens the link in a new tab).  However, when you press the command (ie. apple) key again in an attempt to click on another link, you jump up to the "Get Quotes" text box (ie. and jump up the page).  It should stay where you are in the page so you can click the link!

This appears only to happen on the pages of yahoo finance where there are live updates of the stock quotes.

Reproducible: Always

Steps to Reproduce:
1. Press cmd+mouse click to open a link in a new tab
2. Press cmd again
Actual Results:  
You go back to the top of the page with the cursor in the "Get Quotes" text box.

Expected Results:  
It should have stayed where you are looking at to allow you to click on the link and open a new tab with the link.

Using Mac OSX 10.4.8 running on a MacBook Pro.

Comment 1

12 years ago
I'm having this same exact problem on Mac OS X 10.4.9, Firefox 2.0.0.3 on a PowerBook G4. Very annoying! It used to work fine with Firefox 1.5.
Someone posted about this bug on Colin's blog; I had just seen this myself the other day, so I came hunting for this bug.

So, this "regressed" for Camino when bug 371828 landed in Cocoa widgets, and based on that and comment 1, makes sense that it did for Fx when the equivalent bug 26269 landed earlier in Carbon widgets.

I have a difficult time believing that this is really "our" bug (i.e., that we're sending the wrong key event, but I don't know js, so I could be wrong); more likely it's a TE bug with Yahoo.

It'd be good if some webdev type could verify that we're doing what the page is asking before kicking this to TE.  Firefox:General really isn't the right place for this bug to live, long-term, but confirming and leaving here for lack of a better place for it to go until we know for sure it's TE. 
Blocks: 26269, 371828
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted, regression

Comment 3

12 years ago
This sounds like exactly the same as bug 374700 which Jesse kicked to TE.
Ah, I missed that when I searched TE bugs for this the other day.  It's exactly that.  Since he's done the investigation there, duping.  Thanks, philippe!
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 374700
You need to log in before you can comment on or make changes to this bug.