Feature request: cache remote calendars (e.g. google) locally and update on sync.

RESOLVED DUPLICATE of bug 380060

Status

Calendar
Provider: Local Storage
--
enhancement
RESOLVED DUPLICATE of bug 380060
11 years ago
11 years ago

People

(Reporter: David Gessel, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061006 Sunbird/0.3

It is very nice to be able to see one's google calendar by subscribing to the iCal address and "loading remote calendar" but it is essentially pointless if the calendar is not thus locally cached for access when one is not on line.  If it is only available when one is on line, it is not clear why one would use the read-only sunbird viewer instead of one's browser and the google calendar.   One can export the ical and then reload it... over and over again, thus manually forcing a local cache, but doing so is somewhat tedious.

Reproducible: Always

Steps to Reproduce:
1.subscribe to google calendar
2.shutdown
3.relaunch sunbird on an airplane or somewhere without network access
4.lament empty calendar
Actual Results:  
Calendar is empty

Expected Results:  
Calendar has cache data showing one's vibrant and exciting schedule

Comment 1

11 years ago
Yes, remote calendars need to be cached locally so they can also be shown without a network connection. This is for all remote calendars and is unrelated to Google.

I use only remote calendars (.ics files on a WebDAV server), so that they can be shared, but they are useless without a network connection.

This should be implemented so that:

- When the cached copy is displayed because the remote calendar is unavailable, there is some indication about the fact that it is a cached copy. Possibilities would be: a warning when the loading fails, indicating the date of the last sync. A different background color on the calendars list for the affected calendar(s). An indication in the status bar.

- The calendar becomes read-only, and automatically goes back to read/write (if that was it's original state) at the next successful reload.
(Reporter)

Comment 2

11 years ago
WRT the second implementation point, I'd prefer to be able to create events even when not connected and sync later.  This is the mechanism most "sync" calendar devices use (cell phones, PDA's etc.) and it is a standard UI feature of the sync tools (starfish, moto phone tools, etc) for the user to specify which calendar rules in the case of conflict or to "ask every time."

I frequently use plane time to dig through my inbox, and therein tend to find requests for meetings or appointments or what not and put them on my calendar.  
Is this a duplicate of bug 366923?
OS: Windows XP → All
Hardware: PC → All
Whiteboard: [qa discussion needed]

Comment 4

11 years ago
We need offline support across the entire product. Marking as a dupe to our generic offline bug.  Please add further comments there, so that we have them in one place.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Whiteboard: [qa discussion needed]
Duplicate of bug: 196942

Updated

11 years ago
Duplicate of bug: 380060
You need to log in before you can comment on or make changes to this bug.