Crashes for Thunderbird [@ nsAString_internal::Append]

VERIFIED FIXED

Status

()

--
critical
VERIFIED FIXED
12 years ago
8 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

({crash, top100, topcrash+})

1.8 Branch
crash, top100, topcrash+
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

12 years ago
This is a topcrasher+ for the current 1.8 Branch. It reaches the first position with 50% of all crashes:

http://talkback-public.mozilla.org/reports/thunderbird/TB2x/index.html

It happens for Windows, Linux and Mac.

My talkback id: TB28279269W

Stack Signature	 nsAString_internal::Append 6eb7e65d
Product ID	Thunderbird2
Build ID	2007011004
Trigger Time	2007-01-12 00:24:39.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	xpcom_core.dll + (0003efd6)
URL visited	
User Comments	Thunderbird crashed in background
Since Last Crash	697 sec
Total Uptime	28879 sec
Trigger Reason	Access violation
Source File, Line No.	e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/xpcom/string/src/nsTAString.cpp, line 310
Stack Trace 	
nsAString_internal::Append  [mozilla/xpcom/string/src/nsTAString.cpp, line 310]
0xf18b0c24
StringTail  [../../dist/include/string/nsTDependentSubstring.h, line 149]
0x029a0292
0x91c4006d

Comment 1

12 years ago
Talkback: TB28280394Z ... a little different
Incident ID: 28280394
Stack Signature	nsAString_internal::Append 06dc8213
Product ID	Thunderbird2
Build ID	2007011004
Trigger Time	2007-01-12 01:35:48.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	xpcom_core.dll + (0003efd6)
URL visited	
User Comments	
Since Last Crash	7 sec
Total Uptime	22847 sec
Trigger Reason	Access violation
Source File, Line No.	e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/xpcom/string/src/nsTAString.cpp, line 310
Stack Trace 	
nsAString_internal::Append  [mozilla/xpcom/string/src/nsTAString.cpp, line 310]
0xf18b0c24
nsHTMLTableCellElement::QueryInterface  [mozilla/content/html/content/src/nsHTMLTableCellElement.cpp, line 104]
0x0ff23bf2


--> On a TB 2.0b1 Windows XP SP2
--> TB was really slow since yesterday ... with a lot of "waiting" mouse icon ...
Yesterday and today, TB hang a lot.

Today --> this crash ...
Restart of TB
--> new crash TB28280409Q
Incident ID: 28280409
Stack Signature	js_LookupPropertyWithFlags 7111ee8a
Product ID	Thunderbird2
Build ID	2007011004
Trigger Time	2007-01-12 01:37:23.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	js3250.dll + (00031a45)
URL visited	
User Comments	
Since Last Crash	8 sec
Total Uptime	22855 sec
Trigger Reason	Access violation
Source File, Line No.	e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/js/src/jsobj.c, line 3187
Stack Trace 	
js_LookupPropertyWithFlags  [mozilla/js/src/jsobj.c, line 3187]
js_LookupProperty  [mozilla/js/src/jsobj.c, line 3114]
js_GetProperty  [mozilla/js/src/jsobj.c, line 3491]
nsXPCWrappedJSClass::CallQueryInterfaceOnJSObject  [mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 243]
nsXPCWrappedJSClass::DelegatedQueryInterface  [mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 595]
nsXPCWrappedJS::QueryInterface  [mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 106]
nsEventListenerManager::HandleEvent  [mozilla/content/events/src/nsEventListenerManager.cpp, line 1752]
nsXULElement::HandleDOMEvent  [mozilla/content/xul/content/src/nsXULElement.cpp, line 2230]
nsXULElement::HandleDOMEvent  [mozilla/content/xul/content/src/nsXULElement.cpp, line 2209]
nsXULElement::HandleDOMEvent  [mozilla/content/xul/content/src/nsXULElement.cpp, line 2209]
nsXULElement::HandleDOMEvent  [mozilla/content/xul/content/src/nsXULElement.cpp, line 2209]
PresShell::HandleEventInternal  [mozilla/layout/base/nsPresShell.cpp, line 6425]
PresShell::HandleEvent  [mozilla/layout/base/nsPresShell.cpp, line 6261]
nsViewManager::HandleEvent  [mozilla/view/src/nsViewManager.cpp, line 2559]
nsViewManager::DispatchEvent  [mozilla/view/src/nsViewManager.cpp, line 2246]
HandleEvent  [mozilla/view/src/nsView.cpp, line 174]
nsWindow::DispatchEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 1389]
nsWindow::DispatchMouseEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 6435]
ChildWindow::DispatchMouseEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 6682]
nsWindow::WindowProc  [mozilla/widget/src/windows/nsWindow.cpp, line 1577]
USER32.dll + 0x8734 (0x77d48734)
USER32.dll + 0x8816 (0x77d48816)
USER32.dll + 0x89cd (0x77d489cd)
USER32.dll + 0x8a10 (0x77d48a10)
nsAppShell::Run  [mozilla/widget/src/windows/nsAppShell.cpp, line 159]
nsAppStartup::Run  [mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 152]
main  [mozilla/mail/app/nsMailApp.cpp, line 62]
kernel32.dll + 0x16fd7 (0x7c816fd7)


--> restart of TB: new crash TB28280446X

Incident ID: 28280446
Stack Signature	nsScriptSecurityManager::GetScriptPrincipal cf19d784
Product ID	Thunderbird2
Build ID	2007011004
Trigger Time	2007-01-12 01:39:16.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	THUNDE~1.EXE + (000d9299)
URL visited	
User Comments	
Since Last Crash	17 sec
Total Uptime	22878 sec
Trigger Reason	Access violation
Source File, Line No.	e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/caps/src/nsScriptSecurityManager.cpp, line 1968
Stack Trace 	
nsScriptSecurityManager::GetScriptPrincipal  [mozilla/caps/src/nsScriptSecurityManager.cpp, line 1968]
nsScriptSecurityManager::GetPrincipalAndFrame  [mozilla/caps/src/nsScriptSecurityManager.cpp, line 2077]
nsScriptSecurityManager::GetSubjectPrincipal  [mozilla/caps/src/nsScriptSecurityManager.cpp, line 2119]
nsScriptSecurityManager::doGetSubjectPrincipal  [mozilla/caps/src/nsScriptSecurityManager.cpp, line 1717]
nsScriptSecurityManager::SubjectPrincipalIsSystem  [mozilla/caps/src/nsScriptSecurityManager.cpp, line 1752]
nsContentUtils::IsCallerChrome  [mozilla/content/base/src/nsContentUtils.cpp, line 1029]
PresShell::HandleEventInternal  [mozilla/layout/base/nsPresShell.cpp, line 6393]
PresShell::HandleEvent  [mozilla/layout/base/nsPresShell.cpp, line 6261]
nsViewManager::HandleEvent  [mozilla/view/src/nsViewManager.cpp, line 2514]
nsViewManager::DispatchEvent  [mozilla/view/src/nsViewManager.cpp, line 2246]
HandleEvent  [mozilla/view/src/nsView.cpp, line 174]
nsWindow::DispatchEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 1389]
nsWindow::DispatchFocus  [mozilla/widget/src/windows/nsWindow.cpp, line 6621]
nsWindow::ProcessMessage  [mozilla/widget/src/windows/nsWindow.cpp, line 5194]
nsWindow::WindowProc  [mozilla/widget/src/windows/nsWindow.cpp, line 1577]
USER32.dll + 0x8734 (0x77d48734)
USER32.dll + 0x8816 (0x77d48816)
USER32.dll + 0xb4c0 (0x77d4b4c0)
USER32.dll + 0xb50c (0x77d4b50c)
ntdll.dll + 0xeae3 (0x7c90eae3)
USER32.dll + 0x9402 (0x77d49402)
PeekKeyAndIMEMessage  [mozilla/widget/src/windows/nsAppShell.cpp, line 91]
nsAppShell::Run  [mozilla/widget/src/windows/nsAppShell.cpp, line 128]
nsAppStartup::Run  [mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 152]
main  [mozilla/mail/app/nsMailApp.cpp, line 62]
kernel32.dll + 0x16fd7 (0x7c816fd7)



--> restart of windows
--> TB refuse to restart ... 


Comment 2

12 years ago
reghem@babeltech.com: thanks, but please try to limit bugs to a single set of signatures.  we already have dozens of bugs about crashes under IsCallerChrome and I don't need more.

from my perspective the PresShell::HandleEventInternal crashes are actually the same as the IsCallerChrome crashes, but IsCallerChrome crashes with one signature and ones without IsCallerChrome crash in a slightly different place.

all of these are probably caused by the same layout bug, but for now, I'd like to treat this crash as distinct.
Component: XPCOM → Layout: Tables
QA Contact: xpcom → layout.tables

Comment 3

12 years ago
ok ... i understand ...
(for this comment be less useless ... reinstalling officiel TB2.0b1 on top of TB2.0b1 build of 2007011004 resolved the problem ...)
These crashes started recently:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=MOZILLA_1_8_BRANCH&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-01-08+04&maxdate=2007-01-10+04&cvsroot=%2Fcvsroot
Bug 366016, comment 9 talks about a bad branch merge that caused crashes in Thunderbird. The fix for that went in on 2007-01-10 10:33
So that would mean it should be not a problem anymore in 2007-01-11 builds or later on branch.

Comment 5

12 years ago
I got the crash on a 2.0b1 20070110 on an other machine this morning ...
TB28281201Q and then after restart TB28281216K ...
As the second restart worked this time, i've updated to 2007011103 ... and it seems working now ...

Comment 6

12 years ago
patch is in bug 366016 and is checked in.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

12 years ago
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 7

12 years ago
We have a link to a single checkin => FIXED
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

12 years ago
No more crashes of current builds for 3 days now.

v.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

8 years ago
Crash Signature: [@ nsAString_internal::Append]
You need to log in before you can comment on or make changes to this bug.