NPAPI should not depend on NSPR

RESOLVED DUPLICATE of bug 453883

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 453883
11 years ago
9 years ago

People

(Reporter: Braden, Assigned: Braden)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

11 years ago
npapi.h includes prtypes.h. This dependency could be eliminated by using nptypes.h instead.
(Assignee)

Comment 1

11 years ago
nptypes.h (used by npruntime.h) uses <stdint.h> for that kind of thing; only the types have a _t suffix there. Would it be appropriate to change uses of, e.g., int16 with int16_t in npapi.h (and npupp.h)?
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED

Comment 2

9 years ago
Fixed in bug 453883, NPAPI no longer requires nspr and uses C99 types.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 453883
You need to log in before you can comment on or make changes to this bug.