Error when changing period (daily, weekly, ...) in recurrence dialog [error in nsIDOMWindow.sizeToContent]

RESOLVED WORKSFORME

Status

Calendar
General
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Damian Szczepanik, Unassigned)

Tracking

({regression})

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070112 Calendar/0.4a1

I get error when new task is created

Reproducible: Always

Steps to Reproduce:
1. create new task, set from date, due date, and repeat every 1 week

Actual Results:  
error console:
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMWindow.sizeToContent]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://calendar/content/calendar-recurrence-dialog.js :: updateAccept :: line 378"  data: no]
In opposite to Bug 367184 I'm seeing this issue on Windows too and can confirm as regression:

Works in Calendar/0.4a1 (2006-12-07-13-trunk)
Fails in Calendar/0.4a1 (2006-12-08-00-trunk)

Checkins to directory mozilla/: http://tinyurl.com/26z778
Keywords: regression
Summary: error when creating task and set repeating → Error when changing period (daily, weekly, ...) in recurrence dialog [error in nsIDOMWindow.sizeToContent]
This Problem shows up in some more cases, i.e you enter a numbers in the "Every: XXX Days" text box.

As soon as the UI patch to bug 364148 lands, this will become a Problem since the contents will increase when the text box value is too large, causing the OK button to move partially out of the window.  I assumed that maybe |this != window| in calendar-recurrence-dialog.js, but that doesn't seem to do it.

Since this will become visible to the user, I'm requesting blocking.
Flags: blocking-calendar0.5?
Philipp, does this also happens with 0.5pre builds from mozilla1.8 branch? 
I thought this happens only with trunk builds.
Oh yes, you are right. I'm sorry. Then this obviously dosen't block.
Flags: blocking-calendar0.5?
Component: Tasks → General
QA Contact: tasks → general
I can't reproduce the error message using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.2pre) Gecko/2008071419 Calendar/0.6a1.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.