Open
Bug 366938
Opened 19 years ago
Updated 3 years ago
Misleading error message if SMTP server takes "too much time" to check for spam (Needs prompt like "no ack to sent mail data from SMTP server, wait more? or cancel?")
Categories
(MailNews Core :: Networking: SMTP, enhancement)
MailNews Core
Networking: SMTP
Tracking
(Not tracked)
UNCONFIRMED
People
(Reporter: a.c.li, Unassigned)
References
Details
(Whiteboard: [dupeme?])
User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla Thunderbird version 1.5.0.2 (20060308)
After hitting the "Send button", if the configured MTA takes too much time to check for spam, the mail will be *delivered successfully* but Thunderbird will display a misleading error message that connection to the server failed. This will result in the user resend the message, which ultimately will result in a string of duplicate messages being sent.
(The error message is given below in "Actual Results".)
This is problematic for a number of reasons:
1. Thunderbird's EHLO greeting is acknowledged, so are the MAIL FROM, RCPT TO, and DATA commands; so there is absolutely no problem "connecting" to the server at all, and the server is obviously accepting SMTP connections. The error message is stating a possibility which is essentially ruled out and is factually false.
2. The "problem" is essentially a slow reply to the "." command during the DATA phase. However, both RFC 1123 (5.3.2) and RFC 2821 (4.5.3.2) states that the sender should wait 10 (TEN) minutes after the final "." before deducing that the MTA has stopped responding. In fact in both RFC's there is no timeout less than 2 minutes. So Thunderbird's behaviour is arguably in serious violation of these RFC's.
Thunderbird can issue a warning if it thinks that the server is slow. But it should not issue an error unless it is more sure that what it says is correct (#2 above); in any case part of what it says is very obviously false (#1 above).
Reproducible: Sometimes
Steps to Reproduce:
1. Find or configure an SMTP server which will take a long time to check for spam or viruses
2. Compose a message that will take a long time for scan for viruses/spam
3. If possible, make sure that the box hosting the MTA is having a high system load, to make sure the scan will take a long time
4. Try to send the message
Actual Results:
Thunderbird will deliver the mail successfully but displays the following spurious and misleading error message after a mere 1 (ONE) minute:
Send Message Error
Sending of message failed.
The message could not be sent because connecting to SMTP server (name of server) failed. The server may be unavailable or is refusing SMTP connections. Please verify that your SMTP server setting is correct and try again, or else contact your network administrator.
(OK)
Expected Results:
Thunderbird should wait until the RFC-mandated 10 (TEN) minute timeout limit before giving an "error". Waiting only for 1 minute for a reply to "." is wrong and is in serious violation of the relevant RFC's.
Before this RFC-mandated limit, it can give out a "warning" that it thinks the server is too slow, but giving an error is wrong.
Quoting from RFC 2821:
When the receiver gets the final period terminating the message data, it typically performs processing to deliver the message to a user mailbox. A spurious timeout at this point would be very wasteful and would typically result in delivery of multiple copies of the message, since it has been successfully sent and the server has accepted responsibility for delivery.
Comment 1•18 years ago
|
||
Using Thunderbird version 2.0.0.12 (20080213)
I am seeing the same problem with an Exchange IMAP server. The SMTP-log looks fine, the e-mail is delivered, but it I still get "Send Message Error" ("The message could not be sent because connecting to SMTP server xxx.xxx.xxx failed. The server may be unavailable or is refusing SMTP connections. Please verify that your SMTP server setting is correct and try again, or else contact your network administrator")
Here's the SMTP log from one of the tries:
0[34a18]: SMTP entering state: 0
0[34a18]: SMTP Response: 334 VXNlcm5hbWU6
0[34a18]: SMTP entering state: 14
0[34a18]: SMTP entering state: 17
0[34a18]: Logging suppressed for this command (it probably contained authentication information)
0[34a18]: SMTP entering state: 0
0[34a18]: SMTP Response: 334 UGFzc3dvcmQ6
0[34a18]: SMTP entering state: 19
0[34a18]: SMTP entering state: 18
0[34a18]: Logging suppressed for this command (it probably contained authentication information)
0[34a18]: SMTP entering state: 0
0[34a18]: SMTP Response: 235 2.7.0 Authentication successful.
0[34a18]: SMTP entering state: 19
0[34a18]: SMTP entering state: 3
0[34a18]: SMTP Send: MAIL FROM:<xxx@xxx.xxx> SIZE=1105
0[34a18]: SMTP entering state: 0
0[34a18]: SMTP Response: 250 2.1.0 xxx@xxx.xxx....Sender OK
0[34a18]: SMTP entering state: 6
0[34a18]: SMTP Send: RCPT TO:<xxx@xxx.xxx>
0[34a18]: SMTP entering state: 0
0[34a18]: SMTP Response: 250 2.1.5 xxx@xxx.xxx
0[34a18]: SMTP entering state: 7
0[34a18]: SMTP Send: DATA
0[34a18]: SMTP entering state: 0
0[34a18]: SMTP Response: 354 Start mail input; end with <CRLF>.<CRLF>
0[34a18]: SMTP entering state: 8
0[34a18]: SMTP entering state: 9
0[34a18]: SMTP Send: .
0[34a18]: SMTP entering state: 0
0[34a18]: SMTP Response: 250 2.6.0 <48049EEA.6090202@xxx.xxx> Queued mail for delivery
0[34a18]: SMTP entering state: 10
0[34a18]: SMTP Send: QUIT
0[34a18]: SMTP entering state: 0
Comment 2•18 years ago
|
||
Forgot: this is seen on a Windows XP system, the server is
Microsoft ESMTP MAIL Service, Version: 6.0.3790.3959
Comment 3•18 years ago
|
||
Another addition:
* The message comes almost immediately, not only after 1 minute
* Here's the log for another server which does not show this problem:
0[34a18]: SMTP entering state: 0
0[34a18]: SMTP Response: 250 2.6.0 <4804A1EB.4020901@xxx.xxx> Queued mail for delivery
0[34a18]: SMTP entering state: 10
0[34a18]: SMTP Send: QUIT
0[34a18]: SMTP entering state: 0
0[34a18]: SMTP entering state: 0
0[34a18]: SMTP Response: 221 2.0.0 XXX.XXX.XXX.XXX Service closing transmission channel
0[34a18]: SMTP entering state: 11
0[34a18]: SMTP entering state: 13
So there is another message after the "Queued mail..."
Updated•18 years ago
|
Assignee: mscott → nobody
Updated•16 years ago
|
Blocks: junktracker
Using Thunderbird version 3.0.2
Problem is appearing when sending big attachments(over 400 KB)
Error msg.
Quote start****
Sending of message failed.
The message could not be sent because the connection to SMTP server smtp.mimer.no timed out. Try again or contact your network administrator.
Quote end***
Problem is NOT appearing in Thunderbird version 2.0.0.23 with same settings.
Comment 5•14 years ago
|
||
iirc there are other bugs reporting this issue, besides bug 428461
Whiteboard: [dupeme?]
Updated•14 years ago
|
No longer blocks: junktracker
Comment 6•14 years ago
|
||
IIRC, default was already changed(increased) to mailnews.tcptimeout=100 from 60(seconds).
Per server mail.smtpserver.smtpX.tcptimeout=NNN may be supported.
Try larger tcptimeout value when you experience timeout of SMTP, please.
Does SMTP timeout problem remain even after larger tcptimeout?
Comment 7•14 years ago
|
||
(In reply to Ambrose Li from comment #0)
> Expected Results:
> Before this RFC-mandated limit, it can give out a "warning" that it thinks
> the server is too slow, but giving an error is wrong.
MS Outlook Express perhaps shows dialog like "No response from SMTP server for ... secs, do you wait more? Or cancel sending?" in such case.
I agree with you on such message/dialog/prompt by Tb.
IIRC, I saw proposal like yours in other bugs, but these were merely comment in bug and were not offcial enhancement request at B.M.O.
So change this bug to Severity=Enhancement, although such enhancement may be already requested.
Severity: normal → enhancement
Component: Message Compose Window → Networking: SMTP
OS: Mac OS X → All
Product: Thunderbird → MailNews Core
QA Contact: message-compose → networking.smtp
Hardware: PowerPC → All
Updated•14 years ago
|
Summary: Misleading error message if SMTP server takes "too much time" to check for spam → Misleading error message if SMTP server takes "too much time" to check for spam (Needs prompt like "no ack to sent mail data from SMTP server, wait more? or cancel?")
Updated•3 years ago
|
Severity: normal → S3
You need to log in
before you can comment on or make changes to this bug.
Description
•