Firefox unceasingly spawns or opens windows when clicking on .swf file

RESOLVED WORKSFORME

Status

()

Firefox
File Handling
RESOLVED WORKSFORME
11 years ago
7 years ago

People

(Reporter: Kevin, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-15])

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

When I attempt to download and open a .swf file or double click a .swf file, it
causes Firefox to unceasingly spawn new windows. I have all up to date
Flash, Firefox and Mac OS. I have to force Firefox to quit when this
happens and cannot set Firefox as default program for opening .swf
files. Otherwise Flash plays normally and I have not had problems viewing any sites. I can do a file>open to access a .swf file on my desktop but cannot double-click that file. Very wierd and scary experience.

Reproducible: Always

Steps to Reproduce:
1.downloaded swf from development server
2.double clicked swf to open
3.
Actual Results:  
Same as above

Expected Results:  
should have opened in Firefox window or at least have given me a message asking how I would like to open. 

I had to change the file management option to select Safari for opening .swf files. It worked fine.

Comment 1

11 years ago
Similar to bug 370815, in which the user clicks a link to a PDF file and gets the same results.

Comment 2

9 years ago
Identical bug has appeared in Seamonkey v1.1.12 on Windows XP. 
A .swf file that worked fine on v1.1.8 (and perhaps some later versions too) now causes the same infinite spawn of SeaMonkey windows.
I don't know where between 1.1.8 and 1.1.12 this occurred, but the .swf file is unchanged since it last worked on SeaMonkey.
Blocks: 457723

Comment 3

9 years ago
In SeaMonkey the bug is caused by swf being added in Options/Preferences under 'applications' with SeaMonkey as helper application, causing SeaMonkey to call SeaMonkey in an endless loop when trying to open swf files.
Could be a similar cause in firefox.
This bug was reported using Firefox 3.0 or older, which is no longer supported. The bug has also not been changed in over 500 days and is still in UNCO.
Reporter, please retest this bug in Firefox 3.6.10 or later using a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles. If you still see this problem, please update the bug. If you no longer see the bug, please set the resolution to RESOLVED, WORKSFORME.

This is a mass search of unconfirmed bugs that have no activity on them, so if you feel a bug was marked in error, just remove the CLOSEME comment in the whiteboard within the next month.
Whiteboard: [CLOSEME 2010-11-15]
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.