[Shift]+[F5] should force reload

RESOLVED WONTFIX

Status

()

Firefox
Keyboard Navigation
--
enhancement
RESOLVED WONTFIX
12 years ago
5 years ago

People

(Reporter: Mathias Brodala, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Opera/9.10 (X11; Linux i686; U; de)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.1) Gecko/20061205 Iceweasel/2.0.0.1 (Debian-2.0.0.1+dfsg-1)

If you hold the [Shift] key and press the reload toolbar button, Firefox forces a complete refresh of the current document including forms.

It does nothing when pressing [Shift]+[F5], but it should do the same as above.

Reproducible: Always

Comment 1

9 years ago
It always has been Ctrl when combined with F5, and Shift when combined with the reload button or Ctrl-R. Is Ctrl-F5 not enough?
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> It always has been Ctrl when combined with F5, and Shift when combined with the
> reload button or Ctrl-R. Is Ctrl-F5 not enough?

It actually is, but the current behavior is simply inconsistent, as I did describe in the initial report.
This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Whiteboard: [CLOSEME 5-15-2010]
Version: unspecified → 2.0 Branch
No reply, INCOMPLETE. Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 5

8 years ago
Neither [Shift]+[F5] nor [Ctrl]+[F5] do anything which leads me to believe that [Shift]+Click on the reload button/menuitem is the only way to bypass the cache.
Resolution: INCOMPLETE → FIXED
Then WFM
Resolution: FIXED → WORKSFORME
Or, wait, I'm sorry, please explain clearly what you want, and why you marked this FIXED?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 8

8 years ago
Wasn’t on purpose, I just answered to the report, Bugzilla must’ve preset that. And my request is written clearly in the initial message.
No reply, INCOMPLETE. Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INCOMPLETE
So, you want us to add Shift+f5.
Severity: minor → enhancement
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Whiteboard: [CLOSEME 5-15-2010]
Version: 2.0 Branch → Trunk
Argh, ignore comment 9
(Reporter)

Comment 12

8 years ago
(In reply to comment #10)
> So, you want us to add Shift+f5.

Yeah, that is all I requested.

Comment 13

5 years ago
Shift+F5 now opens the Profiler, so I don't think this enhancement fits anymore.
Component: General → Keyboard Navigation

Comment 14

5 years ago
Closing as wontfix since [Shift]+[F5] now opens profiler.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.