404 on default firstrun page for unofficial builds of Firefox 2.0.0.1

RESOLVED FIXED

Status

RESOLVED FIXED
12 years ago
6 years ago

People

(Reporter: martynas, Assigned: reed)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; OpenBSD i386; en-US; rv:1.8.1.1) Gecko/20061221 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (X11; U; OpenBSD i386; en-US; rv:1.8.1.1) Gecko/20061221 Firefox/2.0.0.1

startup.homepage_welcome_url=http://www.mozilla.org/projects/%APP%/%VERSION%/firstrun/

It should redirect to:

http://www.mozilla.com/${LOCALE}/firefox/${VERSION}/firstrun/

Unfortunately; you do version checking before redirecting and it only does redirect if ${VERSION} =~ /(1.[05]|2.0)/.

${VERSION} in this case is 2.0.0.1.

Reproducible: Always

Steps to Reproduce:
1. update to firefox 2.0.0.1
2. start the browser up
3. wait till "Welcome to Firefox" page loads up
Actual Results:  
Redirect to http://www.mozilla.com/${LOCALE}/firefox/2.0.0.1/firstrun/

Expected Results:  
404: File Not Found
/projects/firefox/2.0.0.1/firstrun/
We are sorry, the file you requested could not be found.

Comment 1

12 years ago
Wil -- can you review this?
(Assignee)

Comment 2

12 years ago
It's not really our problem, but I can fix it.

The reporter installed an unbranded version of Firefox, which uses those URLs.
Assignee: nobody → reed
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

12 years ago
Not a www.mozilla.com problem.
Status: NEW → ASSIGNED
Component: www.mozilla.com → www.mozilla.org
OS: OpenBSD → All
Product: Websites → mozilla.org
QA Contact: www-mozilla-com → www-mozilla-org
Version: unspecified → other
(Assignee)

Updated

12 years ago
Summary: redirection bug creates a bad first-run look after updating to firefox 2.0.0.1 → 404 on default firstrun page for unofficial builds of Firefox 2.0.0.1
(Assignee)

Comment 4

12 years ago
Checking in .htaccess;
/cvsroot/mozilla-org/html/projects/firefox/.htaccess,v  <--  .htaccess
new revision: 1.9; previous revision: 1.8
done

Not sure if that will work. I'll confirm once it reaches stage/production.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
I still get the 404
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

12 years ago
Checking in .htaccess;
/cvsroot/mozilla-org/html/projects/firefox/.htaccess,v  <--  .htaccess
new revision: 1.10; previous revision: 1.9
done

I had an extra slash at the front of the regexp. Should work as soon as this synchronizes. Thanks!
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

12 years ago
Does not work for me.
http://www.mozilla.org/projects/firefox/2.0.0.1/firstrun/
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 8

12 years ago
Anyone?
Not only http://www.mozilla.org/projects/firefox/2.0.0.1/firstrun/ does not work now, the rev. 1.10 has broken http://www.mozilla.org/projects/firefox/2.0/firstrun/ too.
(Reporter)

Comment 9

12 years ago
It's been over a month since my initial request.  What is the hold up?
(Assignee)

Comment 10

12 years ago
The regexp isn't working properly, and I just need to take some time to work on it.

If you know regular expression, see if you can figure out why this isn't working:

RewriteRule ^projects/firefox/([2-9]\.[0-9\.]+)(/.*)?$ http://www.mozilla.com/firefox/$1$2 [R]
(In reply to comment #10)
> If you know regular expression, see if you can figure out why this isn't
> working:
> 
> RewriteRule ^projects/firefox/([2-9]\.[0-9\.]+)(/.*)?$
> http://www.mozilla.com/firefox/$1$2 [R]
> 

How about something like this?

RewriteRule projects/firefox/([2-9](\.[0-9]){1,3})(/.*)?$ http://www.mozilla.com/firefox/$1$3 [R]
Should have been:

RewriteRule ^projects/firefox/([2-9](\.[0-9]){1,3})(/.*)?$
http://www.mozilla.com/firefox/$1$3 [R]

Sorry for the bug spam :)
(Reporter)

Comment 13

12 years ago
Tried on the local web server -- both rules work.
The problem is somewhere else, did you RewriteEngine On?
(Assignee)

Comment 14

12 years ago
(In reply to comment #13)
> Tried on the local web server -- both rules work.
> The problem is somewhere else, did you RewriteEngine On?

Yes, the line right above the RewriteRule is "RewriteEngine on".

Comment 15

12 years ago
What is the status on this?

I'm having the same problem.
FF sends me here:

http://www.mozilla.org/projects/firefox/2.0.0.1/firstrun/
(Assignee)

Comment 16

12 years ago
justdave rocks.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.