the cursor is always busy over message list and mailbox list views

RESOLVED DUPLICATE of bug 455038

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED DUPLICATE of bug 455038
11 years ago
7 years ago

People

(Reporter: Ray Kiddy, Unassigned)

Tracking

PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: version 2 beta 1 (20061201)


I opened TB for the first time with a new profile. I configured the user. The first window shown has three views. The upper view is for the message list. The left-side view is for a list of mailboxes. The bottom right view shows the "Welcome to Mozilla Thunderbird!" page.

When the mouse cursor is over the "Welcome" message, the cursor is an arrow. When I move over either of the other two views, though, the cursor becomes the Carbon busy "watch" icon.


Reproducible: Always

Steps to Reproduce:
1. Start up a new instance of TB.
2. Get through the startup sequence.
3. Move the mouse over the 3 parts of the front window.
Actual Results:  
One gets, forever, the Carbon spinny cursor in the mailbox list view and the message list view.

Expected Results:  
Since the application is in a quiescent state, the cursor should be the regular pointing cursor over all three views of the front window.

Comment 1

11 years ago
version 2 beta 2 (20070116) Linux, GNOME
After creating an account, and then clicking any(?) of the subfolders of it or of Local folders. Doesn't happen on subsequent startups (checked once). -> Large sand clock.

Comment 2

10 years ago
WFM on Debian GNU/Linux with GNOME & metacity with
version 3.0a1pre (2007071203)
version 2.0.0.5pre (20070712)


Do you still see this bug with recent versions of Thunderbird? If not, please close the bug as WORKSFORME. Thanks.
Whiteboard: CLOSEME 2007-08-02
(Reporter)

Comment 3

10 years ago
This is probably going to be specific to a Mac. Does anyone have a Mac that they can check with. I use TB for news, but I do not use it for mail now.
Yes, that's Mac related. Dunno if there is already a bug about. I'll confirm that one for now. I also can see this behavior under Mac OS X 10.4.9. It's not anytime but seems to be happen after reboot or wake-up.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: CLOSEME 2007-08-02
Version: unspecified → 2.0
Assignee: mscott → nobody
Component: General → Mail Window Front End
QA Contact: general → front-end

Comment 5

9 years ago
I think I've encountered the same issue on Mac OS X 10.5.4 with the most recent version of Thunderbird as of this writing (2.0.0.16).

Steps to Reproduce:
1. Start up Thunderbird.
2. Create a new IMAP account.
3. Click on the IMAP Inbox.

Result:
The cursor gets stuck as a watch icon.

I think the reason the cursor icon changes when moving over the "Welcome to Thunderbird!" view is because it crosses the horizontal divider bar, which causes it to temporarily change into the double arrow icon. This seems to reset the cursor and cause it to change into the correct arrow icon inside the "Welcome" view.

Comment 6

9 years ago
when beta 2 comes out in several weeks, please test it.  Someone should be landing a fix in one of the bugs updated in the last week. I don't recall which one
http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
Whiteboard: dupeme

Updated

8 years ago
Severity: normal → minor
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 455038
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved Duplicate!
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.