bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Copies & Folders settings not updated automatically (need to restart to have them set up)

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Casey Eyring, Assigned: Scott MacGregor)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: 20061207

in the Copies & Folders settings, when you chose "Place a copy in: Other: (pick a folder on the server)" for sending messages or drafts and press okay, it does not automatically link it to that folder until you quit out and restart Thunderbird.

Reproducible: Always

Steps to Reproduce:
1. I set up Thunderbird to connect to my school's IMAP server.  Their mailbox names are listed in Mail/sent-mail, and Mail/Drafts folders.  I first had to subscribe to these so they appear in the list under my account.

2. Next, I needed to assign Thunderbird to use mail/sent-mail as my "place a copy in..." for sending messages and mail/drafts for my drafts.

3. Hit save.
Actual Results:  
The changes will not take effect until you restart thunderbird.

Expected Results:  
Updated the icons and linked the folders instead of using the previous settings (It was creating new "Sent" and "Drafts" folders on the IMAP server.)

Comment 1

12 years ago
Which version are you using?

So the bug is that the folder tree doesn't reflect the new "special" folders, but the mails are sent to correct folders?

Comment 2

12 years ago
(In reply to comment #0)
> Expected Results:  
> Updated the icons and linked the folders instead of using the previous
> settings (It was creating new "Sent" and "Drafts" folders on the IMAP
> server.)

The icons not getting changed until restart is a known issue (bug 100239).

The folders getting created may be a new issue; see bug 367016

When you actually send, or save a draft, before restarting, which folder gets used?
(Reporter)

Comment 3

11 years ago
I'm not sure what version I was using at the time.  It was 1.x something.  Version 2 seems to have resolved this issue.

>When you actually send, or save a draft, before restarting, which folder gets
used?

The correct folders are being used for sent-mail and drafts on the version I am using now (version 2.0.0.6)

The icons bug is still present in 2.0.0.6.

Comment 4

11 years ago
probably version 1.5.  You can cc: to bug 100329 for the icon issue.  I'll close this WORKSFORME since your primary problem is gone.  Thanks for the response.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 1.5
(Reporter)

Comment 5

11 years ago
no problem. :)
You need to log in before you can comment on or make changes to this bug.