[Mac] tiling effect in filter testcases

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---
Bug Flags:
blocking1.9 ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

11 years ago
Created attachment 251643 [details]
screenshot of "composite testcase"

Most filter testcases display incorrectly on Mac: stuff ends up tiled all over the place.  I'm attaching a screenshot of the "Composite Testcase" from bug 361070 as an example.
Flags: blocking1.9?

Comment 1

11 years ago
Most likely caused by the unimplemented extend_none case in cairo-nquartz-surface.c:

  http://lxr.mozilla.org/seamonkey/source/gfx/cairo/cairo/src/cairo-nquartz-surface.c#629

Updated

11 years ago
Blocks: 367128
(Reporter)

Updated

11 years ago
No longer blocks: 367128
(Reporter)

Comment 2

11 years ago
This still happens after the cairo update.

Comment 3

11 years ago
Brian, this is another cairo quartz surface backend limitation, if you're interested.

Comment 4

11 years ago
Thanks, I'll get on it.

Comment 5

11 years ago
Created attachment 267621 [details]
expected output

Comment 6

11 years ago
Created attachment 267622 [details] [diff] [review]
patch 1/2: refactor code to show pattern image

refactor code to draw the image from a surface pattern. I'm doing this to make the effect of the next patch clearer - when landed the patch may differ.

Comment 7

11 years ago
Created attachment 267624 [details] [diff] [review]
patch 2/2: implement extend_none for surface patterns

This implements the fix, I now see the same output that tor posted in Minefield. The implementation just draws a single image. Passes the cairo tests too.

The flip oddness is required, if you take it away you'll have the fun of seeing moz draw images, svg upside-down.

I'll be posting a cairo branch for review by vlad & other cairo devs tonight, with this and a few other outstanding mac fixes. Hope to land this soon, definitely before 1.6.

Updated

11 years ago
Depends on: 383960

Comment 8

11 years ago
Works for me on current OS-X nightly.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.