XUL textbox padding smaller on the right (in RTL)

RESOLVED DUPLICATE of bug 463891

Status

()

RESOLVED DUPLICATE of bug 463891
12 years ago
8 years ago

People

(Reporter: eyalroz, Unassigned)

Tracking

({rtl})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

811 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

12 years ago
I noticed that the left padding of a XUL textbox, which is in effect when the direction is set to LTR (dunno about what happens to the left padding in RTL) is wider than the right padding when the textbox is in RTL direction. I find the RTL right-padding insufficient.

BTW - problem seen with TB 1.5, also visible and somewhat worse with SM trunk from 2006-12.
Related to bug 326926 / bug 326123 / bug 365396?
(Reporter)

Comment 2

12 years ago
we're talking 3-4px minimum, not 1px. Although bug 365396 may explain what I'm seeing on the trunk.
Created attachment 251679 [details]
testcase

I think this happens because of:
http://lxr.mozilla.org/seamonkey/source/toolkit/themes/winstripe/global/textbox.css#58
I think stuff needs to be changed to use -moz-padding-start and -moz-padding-end instead.
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> I think stuff needs to be changed to use -moz-padding-start and
> -moz-padding-end instead.

That sounds reasonable... but why not have this padding at the end as well?
I don't know, 4px padding seems a bit too much for me, personally. I think I would prefer it if xul:textboxes would have the same padding as html:inputs.

Comment 6

11 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets
Fixed in bug 463891 -- duping forward
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 463891
You need to log in before you can comment on or make changes to this bug.