Places context menu fx2-parity

RESOLVED FIXED in Firefox 3 alpha2

Status

()

P2
normal
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: mano, Assigned: mano)

Tracking

Trunk
Firefox 3 alpha2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Fx2-parity])

Attachments

(1 attachment, 3 obsolete attachments)

Places context menu fx2-parity.
Created attachment 251707 [details] [diff] [review]
wip

 * Remove Undo menuitem (That's a bug IMO)
 * Add Cut menuitem
 * Remove Select All menuitem
 * Generic handling for menuseparators
 * Hide Delete, Cut and Properties menuitems for links under livebookmark folders
 * Don't show "Reload ..." item for links under livebookmark folders
 * Add a separator above the delete menuitem
Attachment #251708 - Attachment is patch: true
Attachment #251708 - Attachment mime type: application/unknown → text/plain
Created attachment 251998 [details] [diff] [review]
patch

OK, this is ready for a first-pass. Other than the changes listed in comment 1, this introduces a multi-select model for the context-menu similar to the one we have in the legacy bookmarks system.

There is one notable UE difference between this to the legacy context-menu - the Open/Open in New Tab/window menu items are hidden for multiple-nodes selection. Instead, an "Open All in Tabs" item is exposed.
Attachment #251708 - Attachment is obsolete: true
Attachment #251858 - Attachment is obsolete: true
Attachment #251998 - Flags: review?(sspitzer)
Whiteboard: [Fx2-parity]
Duplicate of this bug: 318813
from that patch:

1)  this looks like an error:

+        case Ci.nsINavHistoryResultNodeRESULT_TYPE_REMOTE_CONTAINER:

2)  do we need to worry about RESULT_TYPE_DAY?  (Is this part of the controller used in the history side bar?)

> There is one notable UE difference between this to the legacy context-menu -
> the Open/Open in New Tab/window menu items are hidden for multiple-nodes
> selection. Instead, an "Open All in Tabs" item is exposed.

for this UE change, consider seeking ui-r from beltzner (and/or faaborg)
Comment on attachment 251998 [details] [diff] [review]
patch

r=sspitzer, once you fix that missing "." and please log a spin off bug on the RESULT_TYPE_DAY container.
Attachment #251998 - Flags: review?(sspitzer) → review+
mozilla/browser/components/places/content/controller.js 1.116
mozilla/browser/components/places/content/placesOverlay.xul 1.3
mozilla/browser/components/places/content/utils.js 1.6
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Duplicate of this bug: 334418
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.