[GTK] valgrind warnings when using clipboard while system slow [@ clipboard_contents_received]

RESOLVED DUPLICATE of bug 353547

Status

Core Graveyard
GFX: Gtk
--
critical
RESOLVED DUPLICATE of bug 353547
12 years ago
10 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

({valgrind})

Trunk
x86
Linux
valgrind
Bug Flags:
blocking1.9 ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
I thought I filed this before, but I can't find it.

I think I saw these warnings when trying to copy from the URL bar while my system was slowed down by a compile, etc., although I might have been pasting accidentally.

In any case, the GTK2 clipboard code pretty clearly tries to access a pointer to a variable that was on the stack well after it was on the stack.  If it were to happen while the stack is deeper (which I haven't yet seen, although valgrind wouldn't catch that, I don't think), it could corrupt memory.
Flags: blocking1.9?
(Reporter)

Comment 1

12 years ago
Created attachment 251729 [details]
valgrind warnings
(Reporter)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 353547
Keywords: valgrind
(Assignee)

Updated

10 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.