Text not rendered at all; changing base font size reveals missing text

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
12 years ago
8 years ago

People

(Reporter: amster_girl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

Please see the URL:
http://freemarker.sourceforge.net/docs/dgui_template_overallstructure.html

In Firefox 2.0.0.1 running on Mac OS X 10.4.8 I'm getting text rendering errors.  Simply by changing the base font seems to reveal the missing text.  Safari does not show this same problem.  This might related to another issue I have where characters seem to be overlapping each other, like the character pixel width is not correctly being calculated.

I have taken a few screen shots to show the difference:

- default Firefox font size:
  http://www.flickr.com/photos/amster/360345162/in/set-72157594484392031/

- smaller font size:
  http://www.flickr.com/photos/amster/360345188/in/set-72157594484392031/

- same page in Safari:
  http://www.flickr.com/photos/amster/360345219/in/set-72157594484392031/

I checked the page in Firefox on WinXP and there is no problem in WinXP.

Thanks!
-- Amy



Reproducible: Always

Steps to Reproduce:
1. Go to http://freemarker.sourceforge.net/docs/dgui_template_overallstructure.html
2. Observe missing fonts
3. Shrink font (Option + -) a couple of times
4. Observe revealed fonts
5. Check link in Safari
Actual Results:  
Some text was revealed as the fonts get smaller.

Expected Results:  
The text should always be visible.
This is a mass search for bugs that are in the Firefox General component, are UNCO, and have not been changed for 1000 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the bug, please update this bug. If the issue is gone, please set the resolution to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

8 years ago
Hi, this works fine now on FF 3.6.12 Mac OS version.  Sorry, I didn't see any notification of this until now.
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.