"tab" key works only on <INPUT TYPE="TEXT"> fields, SUBMIT or SELECT fields are omitted

RESOLVED DUPLICATE of bug 187508

Status

()

Toolkit
Form Manager
RESOLVED DUPLICATE of bug 187508
11 years ago
9 years ago

People

(Reporter: Radosław Kojdecki, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; pl; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; pl; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

It isn't possible to move between form fields (except TEXT or TEXTAREA) using TAB (or Shift-TAB) key. To fill form you have to use mouse to select some option from SELECT field or to submit it.

Reproducible: Always

Steps to Reproduce:
1.Open any form with SELECT and SUBMIT field
2.Try to move between fields by TAB key



Expected Results:  
The same as on Linux or Windows

Comment 1

11 years ago
Macs aren't supposed to be keyboard accessible if the respective option isn't set (which it isn't per default).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 187508

Comment 2

11 years ago
Or maybe rather a dupe of bug 349357? Known issue, anyway.
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.