Closed Bug 367294 Opened 17 years ago Closed 13 years ago

Expand/collapse icon appears near To: line in message header pane

Categories

(SeaMonkey :: Themes, defect)

SeaMonkey 1.1 Branch
x86
Linux
defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mozilla.org, Unassigned)

Details

(Keywords: classic, Whiteboard: [Halloween2011Bug])

User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1) Gecko/20061101 SeaMonkey/1.1b
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1) Gecko/20061101 SeaMonkey/1.1b

In the header pane for a message display, there is an expand/collapse icon to the left of the word "To:".  By default, this icon displays as a plus inside a square, and it appears regardless of the number of recipients for the message.  If I click on it, and there's only one recipient, the icon changes to a minus inside a square, but nothing else happens.

In other words, SeaMonkey prompts me to expand the To: list even when it's not necessary.

This problem only occurs in the three-panel display.  If I double-click on a message in the index, that will open the message in its own window.  This window does not have this problem.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Reporter,

do you still see this?

What theme do you use (classic/modern)?

I do not see this on SM 2a Trunk.
Yes, I still see this in Seamonkey 1.1 on Linux using the Classic theme.  I'll try the Seamonkey 2a trunk and report back.
(In reply to comment #3)
> Yes, I still see this in Seamonkey 1.1 on Linux using the Classic theme.  I'll
> try the Seamonkey 2a trunk and report back.
> 

Well, Timur, how was it with Sm 2.0a1pre ?
Seamonkey 2 doesn't work on my Linux system, because I'm (unfortunately) running RHEL 3, and I get this error when trying to start seamonkey:

$ ./seamonkey
./seamonkey-bin: error while loading shared libraries: libpangocairo-1.0.so.0: cannot open shared object file: No such file or directory

I'll keep trying to find a system I can test this on.  
I'm on openSUSE Linux 10.3 where Sm 2.0a1pre loads correctly.

Or else, if it's only the Pango libs which give you problems, you might try (untested) setting MOZ_DISABLE_PANGO=1 in the environment:

       MOZ_DISABLE_PANGO=1 seamonkey
RHEL3 is ancient, which is why it doesn't work.  I don't have the option to upgrade my system.

Your suggestion doesn't work:

$ MOZ_DISABLE_PANGO=1 ./seamonkey
./seamonkey-bin: error while loading shared libraries: libpangocairo-1.0.so.0: cannot open shared object file: No such file or directory
b04825@ld0169-tx32 /tmp/seamonkey$ export MOZ_DISABLE_PANGO=1
b04825@ld0169-tx32 /tmp/seamonkey$ ./seamonkey
./seamonkey-bin: error while loading shared libraries: libpangocairo-1.0.so.0: cannot open shared object file: No such file or directory

I don't see how an environment variable can prevent an executable from attempting to load a library it's linked to.
Since it doesn't work, the point is moot; but some executables on some OSes use "dynamic featuresets" -- if one optional shared library is not found, the feature for which the program needs it becomes disabled, and the program works otherwise. Disabling Pango in SeaMonkey might have made that library unnecessary (but apparently it doesn't).
I tried the latest Alpha on Mac OS X (the fact that it doesn't support OS X 10.3 is bad, but that's another issue).

The latest alpha has the opposite problem.  The little triangle never appears, even when it's supposed to.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008041301 SeaMonkey/2.0a1pre

WFM with Modern theme (on openSUSE Linux 10.3). Both in the Message window and in the Preview pane of the Main window, the little triangle appears, or not, depending on how many addressees there are.
There is bug 382642 covering the twisty issue.

The only thing that holds me back setting this bug as a dupe of bug 382642 is that that bug is for trunk SM2 on linux and windows and its new classic theme. For Mac there is bug 383532.

We should cut down if this bug is really something different.

Reporter, do you really see this on SM1x with a clean, new profile?
Using Seamonkey 1.1.9, I see this problem, but only rarely.  I think it only occurs on some messages.

Take two folders.  In one folder, select a message with a long To: or CC: line.  Resize the window so that the line just barely fits.  In other words, keep making the window wider, one pixel at a time, until the [+] disappears.  Then click on the other folder.  Click on one message in that folder.

Now click on the first folder.  The message with the problem will appear in the pane, and you'll see the [+] in the header.  Clicking on the [+] will just turn it into [-].  Clicking on another message in that folder and then clicking back on the original message will make the [+] go away.  Making the window wider will make the [+] go away.
Version: unspecified → SeaMonkey 1.1 Branch
It isn't logical, but the description of the "Core->Themes" component makes it obvious that it is for bugs specific to one of the two SeaMonkey themes.

Moving the bug there.
Assignee: mail → nobody
Component: MailNews: Main Mail Window → Themes
Product: Mozilla Application Suite → Core
QA Contact: themes
Whiteboard: [Classical]
Version: SeaMonkey 1.1 Branch → 1.8 Branch
Product: Core → SeaMonkey
QA Contact: themes → themes
Version: 1.8 Branch → SeaMonkey 1.1 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
Whiteboard: [Classical] → [Halloween2011Bug]
Keywords: classic
You need to log in before you can comment on or make changes to this bug.