Last Comment Bug 367359 - Attendees Dialog: Zoom buttons don't work
: Attendees Dialog: Zoom buttons don't work
Status: VERIFIED FIXED
:
Product: Calendar
Classification: Client Software
Component: Dialogs (show other bugs)
: Lightning 0.7
: All All
: -- normal with 1 vote (vote)
: 1.0b1
Assigned To: Decathlon
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-18 06:19 PST by Andreas Treumann
Modified: 2011-11-07 03:57 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch_v1 (6.93 KB, patch)
2009-10-03 13:58 PDT, Decathlon
philipp: review+
Details | Diff | Review
Screenshot - Linux (6.64 KB, image/png)
2009-10-10 07:29 PDT, Philipp Kewisch [:Fallen]
no flags Details
patch_v2 (8.16 KB, patch)
2009-10-10 09:42 PDT, Decathlon
no flags Details | Diff | Review
Screenshot - Linux - v2 (8.00 KB, image/png)
2009-10-10 15:50 PDT, Philipp Kewisch [:Fallen]
no flags Details
patch_v3 (6.43 KB, patch)
2009-10-11 05:54 PDT, Decathlon
philipp: review+
Details | Diff | Review

Description Andreas Treumann 2007-01-18 06:19:28 PST
REPRODUCTION:
=============

- open the Attendees Dialog
- push the Zoom Buttons

RESULT:
=======

- nothing happens

EXPECTED RESULT:
================

- pushing the Zoom Buttons changes the zoom of the time scale 

REPRODUCIBLE:
=============

- always
Comment 1 juergen.edner 2007-08-18 13:45:28 PDT
Thunderbird v2.0.0.6 (20070728) / Lightning v0.7pre (2007081804)

This error has still not fixed in the above listed version. The ± zoom buttons doesn't work at all although the pulldown menu works properly.
Comment 2 Stefan Sitter 2007-08-18 15:58:51 PDT
(In reply to comment #1)
This is the reason why the bug is still in Status: NEW instead of FIXED. <https://bugzilla.mozilla.org/page.cgi?id=fields.html#status>
Comment 3 Mike Beltzner [:beltzner, not reading bugmail] 2008-01-29 17:13:12 PST
Oh, crap, sorry, moving back, send hatemail to this address.
Comment 4 [:Aureliano Buendía] 2008-10-05 02:32:13 PDT
I can confirm also on 0.9 release on Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.17) Gecko/20080914 Lightning/0.9 Thunderbird/2.0.0.17 ID:2008091421
Comment 5 Martin Schröder [:mschroeder] 2009-06-26 15:08:39 PDT
Dialog is also present in Sunbird -> Move to Calendar:General
Comment 6 JJ 2009-10-03 01:23:09 PDT
It is already unsolved: 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20091002 Lightning/1.0pre Shredder/3.0pre
Comment 7 Decathlon 2009-10-03 13:58:26 PDT
Created attachment 404449 [details] [diff] [review]
patch_v1

What about this proposal?
Comment 8 JJ 2009-10-04 06:55:24 PDT
It is going to be applied to Lightning nightly builds? It is to embarrassing for me to compile TB+Lightning.

Tested on latest Lightning nightly build and it is still unsolved.
Comment 9 Philipp Kewisch [:Fallen] 2009-10-10 07:29:13 PDT
Comment on attachment 404449 [details] [diff] [review]
patch_v1

Looks good codewise, although at least under linux the toolbar doesn't look like it is supposed to (screenshot follows).

If you just directly put the toolbarbuttons/menulist into the hbox, everything looks fine on linux. If this also works fine under windows, could you attach a patch ready for checkin?
Comment 10 Philipp Kewisch [:Fallen] 2009-10-10 07:29:42 PDT
Created attachment 405660 [details]
Screenshot - Linux
Comment 11 Decathlon 2009-10-10 09:42:54 PDT
Created attachment 405671 [details] [diff] [review]
patch_v2

I added that 'hbox' only to prevent the same flaw I see on your screenshot with Linux. If I delete the box, I get on Windows the same identical error you get with the box.

I tried to put the toolbar just after the main 'hbox' element with every other element inside the toolbar (without added hbox), in this way it looks fine on Windows, how does it look on Linux?
Comment 12 Philipp Kewisch [:Fallen] 2009-10-10 15:50:48 PDT
Created attachment 405715 [details]
Screenshot - Linux - v2

The hbox itself is fine, but you mean with the <hbox> and without the <toolbar> there is the strange border?

I'd suggest to revert to only use a <hbox> containing the toolbar elements and then use the DOM inspector to find out what is causing the strange border.

On linux and with the <toolbar> element, I found that -moz-appearance: toolbar is causing the small border, which is unfortunate. Of course adding -moz-appearance: none fixes this, but this makes the <toolbar> function mostly like a normal <box>.
Comment 13 Decathlon 2009-10-11 05:54:39 PDT
Created attachment 405752 [details] [diff] [review]
patch_v3

(In reply to comment #12)
> 
> The hbox itself is fine, but you mean with the <hbox> and without the 
> <toolbar> there is the strange border?
>

You are right, the <toolbar> element is superfluous. It works fine without it, no extra borders if I delete it.
I attach this patch which merely replaces the static images of the buttons with two toolbarbuttons.
If you think it needs an extra hbox which includes the toolbarbuttons and dropdown menulist, you can add it before the check-in because I've just tried on Windows and it works fine with a such hbox too.
Comment 14 Philipp Kewisch [:Fallen] 2009-10-13 11:48:59 PDT
Comment on attachment 405752 [details] [diff] [review]
patch_v3

Looks good, I'll keep it as is. r=philipp
Comment 15 Philipp Kewisch [:Fallen] 2009-10-13 11:51:03 PDT
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/024643dc0f01>

-> FIXED
Comment 16 Philipp Kewisch [:Fallen] 2011-11-07 03:57:03 PST
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".

Note You need to log in before you can comment on or make changes to this bug.